On Sunday 12 July 2009 11:34:52 Daniel Underwood wrote:
> During installation of Matlab, just after accepting the licnse
> agreement, I get this error:
>
> /home/daniel/matlab-install/update/bin/glnx86/xsetup: error while
> loading shared libraries: /lib/libXp.so.6: ELF file OS ABI invalid
>
> I even tried "# brandelf -t Linux /compat/linux/lib/libXp.so.6" but I
> still get the same error.
>
> How do I fix this?

On Sunday 12 July 2009 15:26:59 Daniel Underwood wrote:
> FYI:
>
> I believe initially libXp.so.6 was not located in /compat/linux/lib/,
> so I copied it there from /usr/local/lib/.  I believe I also tried to
> "brand" the file, but before branding the file and after branding the
> file I get this same error message.

That explains a lot. Remove that file and install /usr/ports/x11/linux-xorg-
libs. The correct libXp.so.6 should then be installed.

The article could use a "pre-requisite" section though. It's not obvious to 
everyone that the linux emulation uses it's own Xorg.

-- 
Mel
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "freebsd-questions-unsubscr...@freebsd.org"

Reply via email to