Andrey V. Elsukov wrote:
Jason Garrett wrote:
Top Post, I know... but has anyone on @current tried a full on ZFS on ROOT

Both Drew and I have both tried the guide at (dead
link now :( )

I get as far as the message I detailed before using parts from another
guide. I am hoping for both of us, that someone here knows even a little

I installed 8.0-BETA1 on ZFS 2 days ago. It works. I did following steps:

1. Boot from bootable USB-flash (Minimal FreeBSD installation with copy of install CD).
I can't figure out how to create bootable USB from Windows. Do not have FBSD system with USB to create. Thus I have booted from DVD made from 8.0-BETA2-amd64-dvd1.iso

2. Create partitions
# gpart show ad0
=>       34  312581741  ad0  GPT  (149G)
         34        256    1  freebsd-boot  (128K)
        290    4194304    2  freebsd-swap  (2.0G)
    4194594  251658240    3  freebsd-zfs  (120G)
  255852834   56728941       - free -  (27G)

3. Create zpool and filesystem hierarchy

4. Install FreeBSD from copy of install CD to ZFS. I used sysinstall with custom
options (Install Root and Media Type)

I am stuck at this point. I have my zpool mounted at /zpool in the FixIt environment. Then I exit FixIt and choose "Custom" from sysinstall. I set appropriate "Options". Next I select my distributions. Finally I hit "Commit" but systinstall complains that I haven't labeled any disks. What step am I missing?



5. Create /etc/fstab, /etc/rc.conf, /etc/src.conf, /boot/loader.conf

6. Install ZFS aware /boot/loader

7. Create zpool.cache

8. Install ZFS boot:
# gpart bootcode -b /zroot/boot/pmbr ad0
# gpart bootcode -p /zroot/boot/gptzfsboot -i 1 ad0

9. Change mount points for zroot pool and reboot.

It's all.
_______________________________________________ mailing list
To unsubscribe, send any mail to ""

Reply via email to