After installing a tape drive and SCSI card in my home system, I got some 
strange behavior that I think isn't directly related, but would like to get an 
expert opinion about.

mobius# uname -a
FreeBSD mobius 7.1-PRERELEASE FreeBSD 7.1-PRERELEASE #0: Fri Sep  5 02:34:20 
CDT 2008     r...@mobius:/usr/obj/usr/src/sys/GENERIC  i386

On July 7, I turned off the system, installed the SCSI card, connected the 
drive and turned it all back on.  This all got correctly detected as (select 
lines from /var/log/messages):

Jul  7 03:10:40 mobius kernel: asr0: <Adaptec Caching SCSI RAID> mem 
0xf4000000-0xf5ffffff irq 17 at device 12.1 on pci2
Jul  7 03:10:40 mobius kernel: asr0: [GIANT-LOCKED]
Jul  7 03:10:40 mobius kernel: asr0: [ITHREAD]
Jul  7 03:10:40 mobius kernel: asr0:   ADAPTEC 2100S FW Rev. 370F, 1 channel, 
256 CCBs, Protocol I2O
Jul  7 03:10:40 mobius kernel: sa0 at asr0 bus 0 target 11 lun 0
Jul  7 03:10:40 mobius kernel: sa0: <EXABYTE VXA-172 3206> Removable Sequential 
Access SCSI-3 device

I stuck in a tape, did a level 0 dump of /home and tested a restore, both of 
which worked perfectly.

Only July 8, I ejected the tape via the button on the front, and then turned 
off the tape drive so the visiting relatives wouldn't complain about the fan 
noise (more from /var/log/messages):
Jul  8 02:27:01 mobius kernel: (sa0:asr0:0:11:0): lost device

That next week, I tried to SSH to this box from work to do some minor random 
thing or another, and I got this sort of error message:
Jul 14 15:27:16 mobius sshd[64290]: error: openpty: Invalid argument
Jul 14 15:27:16 mobius sshd[64293]: error: session_pty_req: session 0 alloc 

I believe I had SSHed to it at least twice over the preceding week, on July 10 
and early in the day on July 14.

As the system was running perfectly in all other ways (well, at least the wife 
hadn't complained her network files were offline, which is the only important 
thing!), it took a few days before I finally got around to logging in at the 
console and rebooting it after which it has seemed to be fine.  The system has 
been eminently stable other than this one issue one time.  

I have not been able to find much from Google about this other than the 
following two items-

A) very specific bugs against different SSH versions than I am using.  Doubt 
this is the problem.

B) some issues some folks have had with needing to create /dev/pty or similar 
items.  While it seems far fetched, this is the first time the system was up 
with a new device and ... I don't know.  New device in the system and an old 
device goes wonky within a week seems to be a bit of a coincidence.  

** Does anyone have any thoughts if these are related or not?  **

Also, any tips, tricks or sites with working with tape drives on FreeBSD would 
be appreciated!  (The handbook is a bit sparse on this point and I'm used to 
autoloaders and better under Windows/Backup Exec).  I'm learning my way around 
camcontrol and mt, but should only need such things in certain circumstances, 
like to get the tape drive "back" after turning it off for a while, right?

_______________________________________________ mailing list
To unsubscribe, send any mail to ""

Reply via email to