On my recently updated (as in world+ports are up-to-date) FreeBSD 6.4
box i tried to get Xorg running, and after building Xorg from ports
and enabling hald and dbus in rc.conf, I get:

  Fatal trap 12: page fault while in kernel mode

This happens when I boot.  Now I'm trying to not start hald and dbus
in rc.conf (I think that's what's causing the kernel problem).  So I
am using the installation CD and going into fixit mode.  The problem
is that I can't find rc.conf to edit.

In /dev:

I tried mounting all of these, and I realized that one of them is /usr
and the other one must be /.  Seemed that most of the files were
there, except for /etc.  It's missing altogether.

fixit# mount /dev/ad0s1d /mnt
fixit# cd /mnt
fixit# find . -type f -name rc.conf

I tried this with all of the devices above and cannot find it.  Like I
said I cannot find /etc at all.

BTW it would be nice if I could fix the underlying kernel page fault
issue, anyone know how?  Uninstall Xorg is one way I guess.
freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-questions-unsubscr...@freebsd.org"

Reply via email to