A question for the gurus, or anyone with an idea on how to fix this... :)

I have just installed FreeBSD 4.8-RC1 (ISO from ftp.au.freebsd.org) on
my Dell Latitude C600 laptop a few days ago.  Everything works perfectly
except sound recording (playback is fine).  The sound hardware in the laptop
is OK, as I've tried it with Windows and Linux under which both recording 
and playback are OK.  I've checked and doublechecked mixer volumes, and
tried a variety of different sound recording software. 

The symptoms of the problem are as follows - I can plug a microphone in and
turn up the mixer volume to the Mic, and set the recording source to the Mic,
which causes the sound from my microphone to be echoed back onto the output
channel.  (So sound mixing is OK).  But in all cases but one if I try to make 
a recording I get silence - the remaining case being rawrec, which just locks
and requires a kill -9 to terminate.  The programs I have tried are:

- wavrec (from wavplay)
- wmrecord
- xwave
- glame
- gnomemeeting (the actual main reason why I want recording to work, BTW)
- rawrec (as mentioned above)

Dmesg output follows:

Copyright (c) 1992-2003 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD 4.8-RC1 #0: Mon Mar  3 01:01:33 GMT 2003
    [EMAIL PROTECTED]:/usr/obj/usr/src/sys/GENERIC
Timecounter "i8254"  frequency 1193182 Hz
CPU: Intel Pentium III (751.71-MHz 686-class CPU)
  Origin = "GenuineIntel"  Id = 0x68a  Stepping = 10
  
Features=0x383f9ff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR,SSE>
real memory  = 134066176 (130924K bytes)
config> di sio1
config> di sn0
config> di lnc0
config> di ie0
config> di fe0
config> di ed0
config> di cs0
config> di fdc0
config> di bt0
config> di aic0
config> di aha0
config> di adv0
config> en ata1
config> po ata1 0x170
config> ir ata1 15
config> f ata1 0
config> q
avail memory = 125231104 (122296K bytes)
Preloaded elf kernel "kernel" at 0xc051c000.
Preloaded userconfig_script "/boot/kernel.conf" at 0xc051c09c.
Pentium Pro MTRR support enabled
md0: Malloc disk
Using $PIR table, 9 entries at 0xc00fbd70
npx0: <math processor> on motherboard
npx0: INT 16 interface
pcib0: <Intel 82443BX (440 BX) host to PCI bridge> on motherboard
pci0: <PCI bus> on pcib0
agp0: <Intel 82443BX (440 BX) host to PCI bridge> mem 0xf4000000-0xf7ffffff at device 
0.0 on pci0
pcib1: <Intel 82443BX (440 BX) PCI-PCI (AGP) bridge> at device 1.0 on pci0
pci1: <PCI bus> on pcib1
pci1: <ATI model 4c46 graphics accelerator> at 0.0 irq 11
pcic0: <TI PCI-1420 PCI-CardBus Bridge> irq 11 at device 3.0 on pci0
pcic0: PCI Memory allocated: 0x88000000
pcic0: TI12XX PCI Config Reg: [ring enable][speaker enable][CSC serial isa irq]
pccard0: <PC Card 16-bit bus (classic)> on pcic0
pcic1: <TI PCI-1420 PCI-CardBus Bridge> irq 11 at device 3.1 on pci0
pcic1: PCI Memory allocated: 0x88001000
pcic1: TI12XX PCI Config Reg: [ring enable][speaker enable][CSC serial isa irq]
pccard1: <PC Card 16-bit bus (classic)> on pcic1
isab0: <Intel 82371AB PCI to ISA bridge> at device 7.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <Intel PIIX4 ATA33 controller> port 0x860-0x86f at device 7.1 on pci0
ata0: at 0x1f0 irq 14 on atapci0
ata1: at 0x170 irq 15 on atapci0
uhci0: <Intel 82371AB/EB (PIIX4) USB controller> port 0xdce0-0xdcff irq 11 at device 
7.2 on pci0
usb0: <Intel 82371AB/EB (PIIX4) USB controller> on uhci0
usb0: USB revision 1.0
uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
chip0: <Intel 82371AB Power management controller> port 0x840-0x84f at device 7.3 on 
pci0
pci0: <unknown card> (vendor=0x125d, dev=0x1998) at 8.0 irq 5
orm0: <Option ROM> at iomem 0xc0000-0xcffff on isa0
atkbdc0: <Keyboard controller (i8042)> at port 0x60,0x64 on isa0
atkbd0: <AT Keyboard> flags 0x1 irq 1 on atkbdc0
kbd0 at atkbd0
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: model Generic PS/2 mouse, device ID 0
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
sio0: type 16550A
ppc0: <Parallel port> at port 0x378-0x37f irq 7 on isa0
ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/8 bytes threshold
plip0: <PLIP network interface> on ppbus0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
pccard: card inserted, slot 0
pccard: card removed, slot 0
ad0: 9590MB <FUJITSU MHR2010AT> [19485/16/63] at ata0-master UDMA33
acd0: CDROM <TEAC CD-ROM CD-224E> at ata1-master PIO4
Mounting root from ufs:/dev/ad0s1a
WARNING: / was not properly dismounted
pccard: card inserted, slot 0
IP packet filtering initialized, divert disabled, rule-based forwarding enabled, 
default to deny, logging disabled
xe0 at port 0x2e8-0x2ef iomem 0xd0000-0xd0fff irq 11 slot 0 on pccard0
xe0: Xircom CEM56, bonding version 0x55, 100Mbps capable, with modem
xe0: DingoID = 0x444b, RevisionID = 0x1, VendorID = 0
xe0: Ethernet address 00:10:a4:f0:25:62
module_register: module pccard/xe already exists!
linker_file_sysinit "if_xe.ko" failed to register! 17
xe0: watchdog timeout; resetting card
pcm0: <ESS Technology Maestro3> port 0xd800-0xd8ff mem 0xf3ffe000-0xf3ffffff irq 5 at 
device 8.0 on pci0
pcm0: <SigmaTel STAC9721/9723 ac97 codec>
cd9660: Joliet Extension (Level 3)

I've spent hours playing with this to no avail.  If anyone can help me here, 
especially if it's just something I'm not quite getting right, that would be 
very much appreciated...


regards,

Simon.


-- 
Simon Phillips, Security Engineer, E-Secure Pty Ltd
Phone: +61 2 9438 3272 Fax: +61 2 9438 4986
PO BOX 375
St Leonards NSW 2065 Australia email: [EMAIL PROTECTED]


To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-questions" in the body of the message

Reply via email to