Hi.

2009/9/9 Алексей Михайлович <merfi...@bk.ru>:
> I want play *.mp3 in to FreeBSD
>
> My system data
> uname -a:
>  6.4-RELEASE FreeBSD 6.4-RELEASE #0: Wed Nov 26 11:43:51 UTC 2008     
> r...@dessler.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC  i386
>
> my sound driver:
>    snd_hda
>
>    $ cat /dev/sndstat
>    FreeBSD Audio Driver (newpcm)
>    Installed devices:
>    pcm0: <Intel 82801I High Definition Audio Controller> at memory 0xf3020000 
> irq 22 kld snd_hda   [20071129_0050] (1p/1r/1v channels duplex default)
> pcm1: <ATI (Unknown) High Definition Audio Controller> at memory 0xf1010000 
> irq 17 kld snd_hda [20071129_0050] (mixer only)
>
> my steps for auto load :
>  1 ee /boot/loader.conf
>    #Sound Driver
>    snd_hda_load="YES" (man snd_hda)
>  2 reboot
>  3 login
>  4 kldstat
>    result kldstat:
> Id Refs Address    Size     Name
>  1    7 0xc0400000 7c89e8   kernel
>  2    1 0xc0bc9000 5c894    acpi.ko
>  3    1 0xc8dcc000 2000     fire_saver.ko
>  4    1 0xc948a000 12000    snd_hda.ko
>  5    1 0xc949c000 1d000    sound.ko
>
> sound driver was loader
>
> I run X server: startx
>  and....... the sound is not present
>
> Next i press Ctrl+Alt+Backspace (down X)
>
> Manually I do an unloading and loading
>   $ kldunload snd_hda
>   $ kldload snd_hda
>
> After these actions all works
>
> Why the such occurs
> Thanks
>
>

What is the output of mixer(8) before and after X is started?

Also, what window manager / desktop environment are you using?

-- 
Glen Barber
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "freebsd-questions-unsubscr...@freebsd.org"
  • Sound in FreeBSD Алексей Михайлович
    • Re: Sound in FreeBSD Glen Barber

Reply via email to