On Thu, 2009-09-17 at 20:45 +0000, Jeronimo Calvo wrote:
> I am getting the following error on #make deinstall
> 
> # make deinstall
> ===>  Deinstalling for emulators/virtualbox
> ===>   Deinstalling virtualbox-3.0.51.r22226
> pkg_delete: file '/usr/local/lib/virtualbox/nls' doesn't exist
> pkg_delete: unable to completely remove directory
> '/usr/local/lib/virtualbox/nls'
> pkg_delete: unable to completely remove directory '/usr/local/lib/virtualbox'
> pkg_delete: couldn't entirely delete package (perhaps the packing list is
> incorrectly specified?)
> 
> Btw, skipping that step and doing a #make reinstall
> 
> it only takes few secs... and gives
> 
> VirtualBox was installed.
> 
> but when i run it as a normal user i get:
> 
> $ VirtualBox
> bash: /usr/local/bin/VirtualBox: No such file or directory

ok maybe the reinstall is broke... try;

# make deinstall
# make install


> 
> 
> 
> 2009/9/17 Craig Butler <craig...@lerwick.hopto.org>:
> > On Thu, 2009-09-17 at 20:32 +0100, Jeronimo Calvo wrote:
> >> True...
> >>
> >> when runned
> >>
> >> $truss VirtualBox
> >>
> >> it gives me Error in SUPR3hardenedmain...
> >>
> >> How do i reinstall the package properly to get VBOX_WITH_HARDENING = 0 ?
> >
> > # cd /usr/ports/emulators/virtualbox/
> > # make clean
> > # make extract patch
> > # edit work/virtualbox-3.0.51r22683/Config.kmk (or LocalConfig.kmk) so
> > that VBOX_WITH_HARDENING = 0
> > # make
> > # make deinstall
> > # make reinstall
> >
> > /Craig B
> >
> >>
> >> Thanks a lot!!
> >>
> >> 2009/9/17 Craig Butler <craig...@lerwick.hopto.org>:
> >> > On Fri, 2009-09-18 at 07:00 +1200, Jonathan Chen wrote:
> >> >> On Thu, Sep 17, 2009 at 06:36:08PM +0000, Jeronimo Calvo wrote:
> >> >> > Hi folks!
> >> >> >
> >> >> > I do have a problem when launching VirtualBox (installed from source),
> >> >> > when launched as a normal user it doesnt lunch. Takes few secs... but
> >> >> > nothing happens...
> >> >>
> >> >> Did you "kldload vboxdrv.ko"?
> >> >
> >> > Hi
> >> >
> >> > Have you tried running it under truss ?
> >> >
> >> > I think you might find that it will say - Error in SUPR3HardenedMain
> >> > and hang...
> >> >
> >> > Solution;
> >> > Rebuild and install Virtualbox port after editing Config.kmk so that
> >> > VBOX_WITH_HARDENING = 0
> >> >
> >> > Hope it helps
> >> >
> >> > Cheers
> >> >
> >> > Craig Butler
> >> >
> >> >
> >> >
> >
> >

_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "freebsd-questions-unsubscr...@freebsd.org"

Reply via email to