On Tue, Mar 04, 2003 at 02:38:29PM +0100, Heinrich Rebehn wrote:
> Heinrich Rebehn wrote:
> >Hi list,
> >
> >trying to boot a FreeBSD kernel with etherboot 5.0.6 results in:
> >
> >...
> >Loading ...(ELF)... segment does 
> >not fit in any memory region
> >
> >What does this mean?

I'm not sure exactly what the message means, but I've had the same
problem recently.  It appears to be related to the network card - not
the boot ROM.  I have one diskless machine up and running - booting from
a ROM on an Intel Pro100.  I have another Intel Pro100 with a built-on
ROM chip.  Now, my known good machine will not boot with this second
card.  I get the same error as you about "segment...memory region".
Both of the cards have the _exact_ same image loaded - by the way,
neither of them have the -DIMAGE_FREEBSD option set.  So apparently the
-DIMAGE_FREEBSD option is not necessary, as I daily boot and use a
machine from a ROM image that does not have this feature.  Also, I have
been getting my ROM images from http://rom-o-matic.org.  I find it very
convenient and altogether easier than using the ports version, not to
mention that the version is newer.  Anyway, my experiments seem to point
to the fact that it has something to do with the card, not the image or
the machine itself.  I have two machines with which to test.  Both
machines boot fine with one card, and both machines fail with the second
card, giving the same error you mention above.  However, I could be way
off base, and I'm definitely going to try loading an image with the
-DIMAGE_FREEBSD option set onto the problem card and see what happens.

> >
> >The kernel is 2390599 bytes. Did i hit a size limitation?
> >I am attaching the Etherboot Config file.
> I have found the solution myself, i forgot "-DIMAGE_FREEBSD", in fact i 
> thought i set it at my 2nd try, but on the 2nd try, i had the floppy write 
> protected, which i didn't notice.. :-(
> Now the kernel gets loaded, last output from etherboot is "........done" 
> and then the system reboots.. :-(

This is probably not a ROM issue, but instead a problem with the kernel
you compiled.  Make sure that you have set the machine type correctly
your kernel config file.  Also, and this one got me, make sure that you
set the appropirate CPUTYPE in your /etc/make.conf file.  For the
longest time I had your exact problem - the kernel would load and then
the machine would immediately reboot.  I beat my head on the wall for
quite some time before I realized that my make.conf file was set to
build for CPUTYPE=i686, but I was trying to boot the kernel on i586.  As
soon as I specified the correct the CPUTYPE all was well.

I hope this helps, and I'll let you know if setting -DIMAGE_FREEBSD
works for my problem card.

> Heinrich

GPG Public Key ID: 0x4250A04C
gpg --keyserver pgp.mit.edu --recv-keys 4250A04C

Attachment: pgp00000.pgp
Description: PGP signature

Reply via email to