taxman wrote:
On Thursday 06 March 2003 02:46 pm, Bill Moran wrote:

I know this doesn't belong on this list, but I can't find any information
about it at all, anywhere. First off, if anyone can point me to
information in lieu of a direct answer, that would be just as helpful. I've searched Apple's site, google at large and the chaos at the mkisofs

Well you help lots of us here, so I'll make a feeble attempt. The only thing I can think of is some pretty generic advice. Try simplifying the problem and breaking it up into it's components till you get to the cause.
Then try new versions of the software you're running. What version of netatalk are you running? how about mkisofs?

That's something I didn't think of. The Netatalk version is getting pretty old. I have tried a number of things already. I tend to suspect OS X itself rather heavily, as it's the only thing that changed (these folkes upgraded from OS 9 to OS X over the last few months). But the guy at the office claimed the CDs aren't correct on OS 9 now either.

Here's the problem:
FreeBSD server that serves files up for Windows and Mac OS X machines
(using Samba and Netatalk).  It has a CD burner in it that is used to
archive old projects.  I have a perl script written that presents a GUI
that a user can pick a directory and click a button to burn it to CD.
FreeBSD is 4.4, cdrtools is 2.0.
Here is the command I'm using to burn the CD:
output = `/usr/local/bin/mkisofs -J -r -apple --netatalk -allow-multidot
-allow-lowercase $target | /usr/local/bin/cdrecord speed=16 dev=4,0 -`

am I getting this right, you're pulling the data over the network using netatalk and then burning it on the freebsd server?
Try eliminating pulling it over netatalk if possible.

No. The data is on the FreeBSD server and was put there by Netatalk (this is their file server) and I'm burning it right off the server.

The result is a CD that works fine on FreeBSD and Windows, but on Mac OS X
it shows all the files and directorys just fine, but the data is corrupt.
It appears as though the resource fork is fine, as images have a viewable
thumbnail, but the data itself is unusable.

Have you tried mounting the iso using vnconfig and seeing if the data is readable that way? On Mac OS?

No, haven't tried that.

How about making the ISO on the Mac and then burning it (on either the Mac machine or the FreeBSD machine.)

We're trying to avoid that. The idea is to have the archiving done at the server so it doesn't tie up a client machine.

Has anyone else seen this, or has any thoughts as to what I might be doing
wrong.  The biggest irritation is that it used to work just fine, and I
don't remember changing anything.

Hmm, that is a bummer. I had weird problems when I used netatalk, but it was never important to me so I never tried hard to fix it.
Another thought, if you're using MacOS X, why not try NFS instead of netatalk?

It's something to try. I think with the OS X machines they're actually connecting through Samba now.

I have a workaround now.  If I disable all the Apple options when the disk is
burned, I end up with a pure Rockridge/Joliet CD that the Mac interprets fine.
They don't have fancy icons or resource forks, but at least the data is readable.

The client isn't up for spending any more money to research this, but I'm
interested to see what's wrong.  If anyone has any suggestions, I have a Mac
here, and I can burn CDs off FreeBSD to test things.

Bill Moran
Potential Technologies

To Unsubscribe: send mail to [EMAIL PROTECTED] with "unsubscribe freebsd-questions" in the body of the message

Reply via email to