On Mon, Mar 10, 2003 at 11:37:53PM -0500, Paul Lathrop wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> I must admit I feel silly having to ask, but I've been banging my head 
> against this for a couple days now and I am completely stumped.
> 
> I just recently switched from Slackware Linux 8.0 to FreeBSD. There are 
> a couple of scripts I use for my own convenience that I ran setuid root 
> on my Linux box. All that I had to do was make sure the scripts were 
> owned by root, and then do a chmod 4711 on them to make it work in 
> Linux. I just set up a script on FreeBSD - the first time I've actually 
> done it since I switched. I followed the same procedure, but when I run 
> the script as a normal user, it does not run with elevated priveleges.

Dunno about Linux, but every other modern UNIX out there doesn't allow
setuid scripts.
-- 
Jonathan Chen <[EMAIL PROTECTED]>
-----------------------------------------------------------------------
"I love deadlines. I like the whooshing sound they make as they fly by"
                                                        - Douglas Adams

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-questions" in the body of the message

Reply via email to