Sunday,  1 November 2009 at 23:43:26 +0100, usleepl...@gmail.com said:
> Dear Peter,
> 
> On Sat, Oct 31, 2009 at 8:18 PM, Peter Harrison
> <peter.piggy...@virgin.net>wrote:
> 
> > Hi all,
> >
> > Can anyone advise what I'm doing wrong trying to install
> > multimedia/dvdauthor. Here's the end of the error:
> >
> > if cc -DHAVE_CONFIG_H -I. -I. -I.  -DSYSCONFDIR="\"/usr/local/etc\""
> > -I/usr/local/include/libxml2 -I/usr/local/include
> > -I/usr/local/include/ImageMagick -I/usr/local/include/freetype2
> > -I/usr/local/include -I/usr/local/include/fribidi -I/usr/local/include
> > -I/usr/local/include -Wall -DICONV_CONV=yes -MT subreader.o -MD -MP -MF
> > ".deps/subreader.Tpo" -c -o subreader.o subreader.c; \
> >        then mv -f ".deps/subreader.Tpo" ".deps/subreader.Po"; else rm -f
> > ".deps/subreader.Tpo"; exit 1; fi
> > subreader.c: In function 'sub_read_line_aqt':
> > subreader.c:661: warning: comparison with string literal results in
> > unspecified behaviour
> > subreader.c:661: warning: comparison with string literal results in
> > unspecified behaviour
> > subreader.c: In function 'sub_read_line_subrip09':
> > subreader.c:717: warning: comparison with string literal results in
> > unspecified behaviour
> > subreader.c: In function 'sub_fribidi':
> > subreader.c:1082: error: 'FRIBIDI_TRUE' undeclared (first use in this
> > function)
> > subreader.c:1082: error: (Each undeclared identifier is reported only once
> > subreader.c:1082: error: for each function it appears in.)
> > subreader.c:1083: error: 'FRIBIDI_FALSE' undeclared (first use in this
> > function)
> > subreader.c:1102: warning: passing argument 3 of 'fribidi_log2vis' from
> > incompatible pointer type
> > gmake[2]: *** [subreader.o] Error 1
> > gmake[2]: Leaving directory
> > `/usr/ports/multimedia/dvdauthor/work/dvdauthor-0.6.14/src'
> > gmake[1]: *** [all] Error 2
> > gmake[1]: Leaving directory
> > `/usr/ports/multimedia/dvdauthor/work/dvdauthor-0.6.14/src'
> > gmake: *** [all-recursive] Error 1
> > *** Error code 1
> >
> > This is on:
> >
> > FreeBSD laptop.piggybox 7.2-STABLE FreeBSD 7.2-STABLE #0: Sat Oct 10
> > 13:54:52 BST 2009     r...@laptop.piggybox:/usr/obj/usr/src/sys/LAPTOP
> >  i386
> >
> > With a ports tree updated last night.
> >
> > What am I missing?
> >
> 
> i don't think you are missing anything:  i have a slighty older ports tree
> from september, and it fails as well.
> 
> i assume the port is "broken". ( i will take a look if i can identitfy the
> problem )

Thanks - good to know it's not just me. I'll drop a line to the maintainer.

Peter.


> 
> regards,
> 
> usleep
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "freebsd-questions-unsubscr...@freebsd.org"

Reply via email to