All,

I'm having trouble getting 7.2-p4 to run. I'm using nanoBSD, either
under VMware using a virtual serial null-modem or on an Alix
Soekris-like serial-only CF-based device, both show this problem: my
serial console does not display kernel messages, they all go to the
VGA console!

I'm using the nanoBSD cust_comsole function to enable the console.
Relevant files are shown here:

/boot.config:
-h -S57600

/etc/ttys, only one line is "on":
ttyd0   "/usr/libexec/getty std.57600"  xterm   on secure

These are still in my kernel conf, if I remove these I get no kernel
messages at all (kernel boots fine with this though):
device          atkbdc          # AT keyboard controller
device          atkbd           # AT keyboard
device          kbdmux          # keyboard multiplexer
device          vga             # VGA video card driver

I have also tried to set this in the loader, no luck:
hint.sio.0.flags="0x30"

On the serial console, I see the boot manager (boot0) and the loader
just fine. "show" in the loader says "console=comconsole" so that
seems to be fine. However all kernel output goes to the VGA console. I
*do* get a login prompt after a while on the serial console though.

If I boot the same kernel over PXE on the ALIX, the kernel messages
*do* go to the serial console...

What am I overlooking?

Thanks,

Sven
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "freebsd-questions-unsubscr...@freebsd.org"

Reply via email to