Hello.

Please respond also to my eMail address, since I'm not subscriber of these lists! Thanks.


Since I utilise a MSI Radeon R4670/512 RV730-based graphics card, I'im incapable of using either

x11-drivers/xf86-video-ati or
x11-drivers/xf86-video-radeonhd[-devel]


The box is a ASUS P5K-Premium based system (Intel P35 chipset, CPU Intel Q6600), running FreeBSD 8.0-RC2/amd64 successfully. The X11 subsystem ist the most recent as one can find in the ports collection. I'll attach the logfile of the currently running Xserver.

My box got a new 24 inch TFT display so using VESA driver or lower resolutions than 1920x1200 isn't acceptable. The situation is as follows:

In all cases it doesn't matter wheter kernel module 'drm.ko' is loaded or not.

Driver 'radeon' (x11-drivers/xf86-video-ati) crashes the box immediately without any messages. I can see the xdm-login requester, but just before this shows up, I realise that the mousepointer sprite gets a kind of 'distorted', it shows up some 'stripes'. They vanish. When log in and the desktop is about to show up (using windowmaker), the screen stays black, the box crahes and in some lucky situations, it reboots, in less lucky situations it remains frozen.

Driver 'radeonhd' (xf86-video-radeonhd-1.2.5_2) works, but without 'options EXA' and without 'options DRI'. It is bumpy, but shows a 1920x1200 pixel screen in full colours.

Driver 'radeonhd' (xf86-video-radeonhd-1.3.0) doesn't work, it shows the same behaviour as 'radeon' (xf86-video-ati). I can wathc the mouse pointer sprite getting striped and a kind of distorted, then the box crashes.

Those crashes occur mostly when switching from xdm-login requester to desktop. In some cases I can switch to the console (pressing ctrl-alt-[F1--F7]), but at some point, this also freezes/crashes the box.

I'm a little bit confused, since the ATi-RV730LE chipset is supposed to be supported. I run another box, an older nVidia CK804-based Athlon3500+ box equipted with a MSI R4830/512 graphics card. The same base OS (FreeBSD 8.0-RC2/amd64. The graphics board runs perfectly with ALL(!) radeon-type drivers, options EXA and DRI enabled, kernel module drm.ko loaded.

Can someone help? Since I do not have Windows XP/Vista/7 running on the box in question, I can not update the firmware of the MSI R4760 with a potentially existing firmware-update (since those tasks can only be performed via a special software from MSI running on XP/Vista as far as I know).

Thanks in advance,
Oliver

_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "freebsd-questions-unsubscr...@freebsd.org"

Reply via email to