Hello,

I wanted to create a shared directory writable by all users. When it initially 
failed, I assumed there may be a blanket ban on writing to directories owned by 
root. Today, I was able to write to the root-owned "Share" directory. However, 
when I re-created the directory owned by a special-purpose "Share" user, I ran 
into the  same problem again.

$ cd
$ pwd
/home/james
$ cd /home/Share
$ ls -la
total 4
drwxrwxr-x  2 root  users  512 Nov 14 09:39 .
drwxr-xr-x  5 root  wheel  512 Nov 14 09:39 ..
$ grep users /etc/group
users:*:100:james,backup
$ cat > test.txt
What? now it worked?
$ ls
test.txt
$ rm test.txt

***After creating a special "Share" user***

$ cd /home/Share
$ ls -la
total 4
drwxrwxr-x  2 Share  Share  512 Nov 17 21:04 .
drwxr-xr-x  5 root   wheel  512 Nov 17 21:04 ..
$ cat > test.txt
cannot create test.txt: Permission denied
$ grep Share /etc/group
Share:*:1003:james,backup
$

Incidentally, I had another reason for creating a special-purpose "Share" user: 
I am exporting /home to Debian (Linux) clients. Since the "system" groups 
conflict with the Debian choices, I modified /var/yp/Makefile to only export 
users and groups in the range of 1001-2000.

Regards,

James Phillips

PS: the first time, I made the mistake of adding whitespace in /etc/group 
(daily run checks this somehow)
Is a blank line required at the end of the file?
PPS: Tried adding blank line: no effect.



      __________________________________________________________________
Make your browsing faster, safer, and easier with the new Internet Explorer® 8. 
Optimized for Yahoo! Get it Now for Free! at 
http://downloads.yahoo.com/ca/internetexplorer/
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "freebsd-questions-unsubscr...@freebsd.org"

Reply via email to