This was not an upgrade but rather a fresh install. I included 
compat7x-amd64-7.2.702000.200906.1 in the install. I've found other packages 
that are giving the same error. Recompiling all of the ports is something I 
want to avoid. The install is done through an automated process that builds a 
FreeBSD 8 image using a custom script, combining our custom kernel with a bunch 
of binary packages we want to include in the image. The result is a tarball 
image, and that image can then be taken and installed directly onto our target 
systems via a USB boot stick.

We've used the same technique for 7.0 and it's worked fine. I was just thinking 
though: We do build our custom kernel, and the build is being done, for now, on 
our 7.0 build server. I got the binary ports from the net, and I assume at 
least some have been built on an 8.0 system. Can you combine binaries of ports 
that have been built on an 8.0 system with a custom kernel that was built on a 
7.0 system?

-----Original Message-----
From: Norbert Papke [mailto:npa...@acm.org] 
Sent: Tuesday, November 17, 2009 10:47 PM
To: freebsd-questions@freebsd.org
Cc: Peter Steele
Subject: Re: ELF library not found error

On November 17, 2009, Peter Steele wrote:
>  I've installed an 8.0 RC3 system and
>  included Python 2.5, 2.6, and 3.1. The 2.6 version appears to run fine.
>  However, for both 2.5 and 3.1 I get the error:
> 
> ELF interpreter /libexec/ld-elf.so.1 not found
> 
> What might cause this error?

If you upgraded from 7.x, you need to install the misc/compat7x port. 

Even better, rebuild all your ports.  It will save you a lot of grief in the 
long run.

Cheers,

-- Norbert Papke.
   npa...@acm.org


http://saveournet.ca
Protecting your Internet's level playing field
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "freebsd-questions-unsubscr...@freebsd.org"

Reply via email to