On 6/28/10 5:13 PM, Dan D Niles wrote:

The release notes for FreeBSD 7.3 said that it could boot to zfs.  I did
not see any options for doing that via the normal install.  I followed
the instructions here:


When I reboot, I get:

can't load 'kernel'

I wiped the disk and tried again to verify I didn't miss a step.  Same

I saw a suggestion that zfs.cache needed to be copied.  I did that
during the setup, but I tried doing it again from Fixit.  Same result.

You don't need this step for 7.3.

The other suggestion I saw was to do section 2 step 7 "again."  That
shouldn't be necessary for 7.3, but I tried it anyway.  Still seeing
"can't load 'kernel'."

Any suggestions for getting FreeBSD 7.3 to boot to ZFS?

Can you try the following at the loader prompt, where you see the FreeBSD boot options?

   load zfs
   load opensolaris # should not be necessary, but just to be safe


Glen Barber
freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-questions-unsubscr...@freebsd.org"

Reply via email to