On Thu, Aug 16, 2012 at 05:33:20PM +0200, Hartmann, O. wrote:
> I ran into a very delicate and nasty situation.
> On several boxes, FreeBSD 9.1-PRE and FreeBSD 10-CURRENT (build of
> CURRENT sources from yesterday, r239295 Wed August 15 17:04:51 CEST 2012
> amd64, I had to recompile all requirements of port Apache22, since after
> the port update it core dumped.
> On FreeBSD 9.1-PRE, with pkg(ng), things went well. Recompilation and
> installation of all "portmaster -f apache-2.2" requirements went perfect.
> On both FreeBSD 10-CURRENT boxes it ended up in a mess, all of a
> sudden(!), while reinstalling port security/cyrus-sasl2, things started
> to fail in a dramatik way!
> On both FBSD 10 boxes, the installation of the port security/cyrus-sasl2
> got corrupted by "install" and/or "mtree" dumping core and signalling
> SIGNAL 11. Booting into multiuser mode is impossible, login core dumps
> SIGNAL 11, many other daemons, too. The only way is to boot into single
> user mode.
> An installation failed due to pkg(ng) was missing libarchive.so via

There is pkg-static for recovering in this type of situation.

> portmaster or via core dumping install(1). By installing on one box, my
> home box, port security/cyrus-sasl2 manually, luckily install(1) and
> mtree(1) didn't coredump and it worked - and this precedure rescued me.
> But on my lab's development box, it doesn't work!
> On this specific box, where this nasty problem also occured the same way
> by simply recompiling everything for port www/apache22, including the
> reinstallation of port security/cyrus-sasl2. Nearly every binary is
> suddenly coredumping (as on the home box). login, vi, install, devfs,
> syslogd, mtree, id, find ... a whole lot of binaries seem to be
> compromised by something I do not see (libsasl2.so perhaps?).
> I tried to help myself via copying /rescue/vi to /usr/bin/vi to have at
> least a working vi. But in /rescue, I can not find install or mtree. I'm
> not familiar with the sophisticated ways of /rescue. Where are
> install(1) and mtree(1)?
> Trying to reinstall security/cyrus-sasl2 from single-user fails due
> install coredumps. pkg(ng) fails due to missing libpkg.so.5 and even
> rejects being reinstalled. But /usr/local/lib/libpkg.so.0 is even there!
> Disabling the use of pkg with commenting out WITH_PKGNG=yes in
> /etc/make.conf leads to the above issues with mtree and install.
> Disabling this pkgng tag leads to reinstallation of missing packages,
> which are store in the pkgng sqlite format and not as ASCII anymore, but
> then I get
> /var/runld-elf.so.hints: No such file or directory

Is this a typo, or literal transcription?  (The missing "/" between
'run' and 'ld-elf.so.hints', that is.)

> Error: shared library "iconv.3" does not exist.
> But most of the libs have never been touch! So what is the loader
> complaining about?
> Well, I'm floating like a dead man in the water and I'm glad that one
> box survided although suffering from the same symptomes.
> I tried to find rescue images and a rescue DVD of a snap shot server,
> but there is no way to crawl through the informations on the web pages
> towards a snapshot. All folders end up in 2011 and highly outdated
> (www.freebsd.org, I didn't look at mirrors since I thought the main
> server carries the most recent stuff). This isn't funny. No lead, no
> hint, even in the download section.

Yes, I have been complaining about this for a while now...

> If someone has some hints how to recompile the sources with an emergency
> booted disk, I highly appreciate some desater advice. Maybe the release
> of FreeBSD-10-CURRENT sources I compiled do have accidentally a nasty
> bug, so it would be nice to update the sources and have a complete
> recompilation done.

If you can get booted into a recovery medium, you can mount /usr/src and
/usr/obj from the hosed system, and should be able to
installworld/installkernel into the hosed system with DESTDIR set.


freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-questions-unsubscr...@freebsd.org"

Reply via email to