On 04/24/13 11:55, Bernt Hansson wrote:
2013-04-24 12:30, Arthur Chance skrev:
On 04/24/13 09:18, Bernt Hansson wrote:
Hello list!

I have set up a diskless machine with 8.3-stable and i as a user can log
in, but when I try to log in as root it won't work. How to resolv that
issue. I have tried with and without password but the computer said no.

How did it say no? What does the entry for root in /etc/passwd say?


root:*:0:0:Charlie &:/root:/bin/csh

That's not logging in directly as root, that's using su as a normal user. Only members of wheel group can use su. Try logging in directly on the console as root. That should work unless you've marked the console as insecure or have an "impossible" password in /etc/master.passwd.

In the long run you need to add your normal user to wheel group so you can use su. Can you edit the diskless machine's /etc/group from the server that's supplying its disk(s)? In the days when I ran diskless systems I usually found it easier to work on the diskless systems' config files via the server.

In the dungeons of Mordor, Sauron bred Orcs with LOLcats to create a
new race of servants. Called Uruk-Oh-Hai in the Black Speech, they
were cruel and delighted in torturing spelling and grammar.

                _Lord of the Rings 2.0, the Web Edition_
freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-questions-unsubscr...@freebsd.org"

Reply via email to