I am interested in installing the gaim port, but it seems there is recursive
dependancy that forces it to install XFree86 v4.3.0. I don't mind this, but
unfortunately I end up with a build failure for one of the clients. I suppose
someone has sucessfully jumped over this obstacle, and would ask for their
advise. I seriously need to confer with some Windows lusers somewhere!


If it might help, I am running FreeBSD 5.1-RC. The error is below:


===>   gaim-0.64 depends on executable: gmake - found
===>   gaim-0.64 depends on executable: libtool - found
===>   gaim-0.64 depends on file: /usr/local/bin/perl5.8.0 - found
===>   gaim-0.64 depends on executable: pkg-config - found
===>   gaim-0.64 depends on shared library: gtkspell.0 - not found
===>    Verifying install for gtkspell.0 in /usr/ports/textproc/gtkspell2
===>   gtkspell2-2.0.4 depends on executable: gmake - found
===>   gtkspell2-2.0.4 depends on executable: libtool - found
===>   gtkspell2-2.0.4 depends on file: /usr/local/bin/perl5.8.0 - found
===>   gtkspell2-2.0.4 depends on executable: pkg-config - found
===>   gtkspell2-2.0.4 depends on shared library: pspell.15 - found
===>   gtkspell2-2.0.4 depends on shared library: X11.6 - found
===>   gtkspell2-2.0.4 depends on shared library: glib-2.0.200 - found
===>   gtkspell2-2.0.4 depends on shared library: atk-1.0.200 - found
===>   gtkspell2-2.0.4 depends on shared library: pango-1.0.200 - not found
===>    Verifying install for pango-1.0.200 in /usr/ports/x11-toolkits/pango
===>  Installing for pango-1.2.3
===>   pango-1.2.3 depends on file: /usr/X11R6/lib/X11/fonts/TTF/luximb.ttf - not found
===>    Verifying install for /usr/X11R6/lib/X11/fonts/TTF/luximb.ttf in 
/usr/ports/x11-fonts/XFree86-4-fontScalable
===>   XFree86-fontScalable-4.3.0 depends on executable: ucs2any - not found
===>    Verifying install for ucs2any in /usr/ports/x11/XFree86-4-clients
===>  Building for XFree86-clients-4.3.0_2
making all in lib/lbxutil/lbx_zlib...
making all in lib/lbxutil/delta...
making all in lib/lbxutil/image...
making all in programs/appres...
making all in programs/bdftopcf...
making all in programs/bitmap...
making all in programs/beforelight...
making all in programs/editres...
making all in programs/fslsfonts...
making all in programs/fstobdf...
making all in programs/iceauth...
making all in programs/ico...
making all in programs/listres...
making all in programs/luit...
making all in programs/makepsres...
making all in programs/dpsinfo...
making all in programs/dpsexec...
making all in programs/texteroids...
making all in programs/mkcfm...
making all in programs/mkfontdir...
making all in programs/mkfontscale...
cc -O -pipe -mcpu=pentiumpro -ansi -Dasm=__asm -Wall -Wpointer-arith -Wundef   
-I/usr/local/include/freetype2 -I/usr/local/include   
-I/usr/ports/x11/XFree86-4-clients/work/xc 
-I/usr/ports/x11/XFree86-4-clients/work/xc/exports/include  -I/usr/X11R6/include 
-DCSRG_BASED  -DFUNCPROTO=15 -DNARROWPROTO   -DFREETYPE2   -c mkfontscale.c
mkfontscale.c: In function `doDirectory':
mkfontscale.c:355: `PS_FontInfoRec' undeclared (first use in this function)
mkfontscale.c:355: (Each undeclared identifier is reported only once
mkfontscale.c:355: for each function it appears in.)
mkfontscale.c:355: `t1info' undeclared (first use in this function)
mkfontscale.c:355: `t1info_rec' undeclared (first use in this function)
mkfontscale.c:355: warning: left-hand operand of comma expression has no effect
mkfontscale.c:412: warning: implicit declaration of function `FT_Get_PS_Font_Info'
mkfontscale.c: In function `checkEncoding':
mkfontscale.c:589: warning: implicit declaration of function `FT_Has_PS_Glyph_Names'
*** Error code 1

Stop in /usr/ports/x11/XFree86-4-clients/work/xc/programs/mkfontscale.
*** Error code 1

Stop in /usr/ports/x11/XFree86-4-clients/work/xc/programs.
*** Error code 1

Stop in /usr/ports/x11/XFree86-4-clients.
*** Error code 1

Stop in /usr/ports/x11-fonts/XFree86-4-fontScalable.
*** Error code 1

Stop in /usr/ports/x11-toolkits/pango.
*** Error code 1

Stop in /usr/ports/textproc/gtkspell2.
*** Error code 1

Stop in /usr/ports/net/gaim.





-Wash

-- 
Odhiambo Washington   <[EMAIL PROTECTED]>  "The box said 'Requires
Wananchi Online Ltd.  www.wananchi.com      Windows 95, NT, or better,'
Tel: +254 2 313985-9  +254 2 313922         so I installed FreeBSD."   
GSM: +254 72 743223   +254 733 744121       This sig is McQ!  :-)


"I like work ... I can sit and watch it for hours."
_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to