When trying to portupgrade samba-devel to the latest from cvsup, I get:

Compiling dynconfig.c
In file included from include/includes.h:429,
                 from dynconfig.c:21:
/usr/local/include/gssapi/gssapi.h:285: warning: `GSS_C_INDEFINITE'
redefined
/usr/include/gssapi.h:218: warning: this is the location of the previous
definition
/usr/local/include/gssapi/gssapi.h:298: warning:
`GSS_C_CALLING_ERROR_MASK' redefined
/usr/include/gssapi.h:340: warning: this is the location of the previous
definition
/usr/local/include/gssapi/gssapi.h:299: warning:
`GSS_C_ROUTINE_ERROR_MASK' redefined
/usr/include/gssapi.h:341: warning: this is the location of the previous
definition
/usr/local/include/gssapi/gssapi.h:300: warning:
`GSS_C_SUPPLEMENTARY_MASK' redefined
/usr/include/gssapi.h:342: warning: this is the location of the previous
definition
/usr/local/include/gssapi/gssapi.h:308: warning: `GSS_CALLING_ERROR'
redefined
/usr/include/gssapi.h:351: warning: this is the location of the previous
definition
/usr/local/include/gssapi/gssapi.h:310: warning: `GSS_ROUTINE_ERROR'
redefined
/usr/include/gssapi.h:353: warning: this is the location of the previous
definition
/usr/local/include/gssapi/gssapi.h:312: warning: `GSS_SUPPLEMENTARY_INFO'
redefined
/usr/include/gssapi.h:355: warning: this is the location of the previous
definition
/usr/local/include/gssapi/gssapi.h:315: warning: `GSS_ERROR' redefined
/usr/include/gssapi.h:358: warning: this is the location of the previous
definition
/usr/local/include/gssapi/gssapi.h:325: warning:
`GSS_S_CALL_INACCESSIBLE_READ' redefined
/usr/include/gssapi.h:368: warning: this is the location of the previous
definition
/usr/local/include/gssapi/gssapi.h:327: warning:
`GSS_S_CALL_INACCESSIBLE_WRITE' redefined
/usr/include/gssapi.h:370: warning: this is the location of the previous
definition
/usr/local/include/gssapi/gssapi.h:329: warning:
`GSS_S_CALL_BAD_STRUCTURE' redefined
/usr/include/gssapi.h:372: warning: this is the location of the previous
definition
/usr/local/include/gssapi/gssapi.h:334: warning: `GSS_S_BAD_MECH'
redefined
/usr/include/gssapi.h:377: warning: this is the location of the previous
definition
/usr/local/include/gssapi/gssapi.h:335: warning: `GSS_S_BAD_NAME'
redefined
/usr/include/gssapi.h:378: warning: this is the location of the previous
definition
/usr/local/include/gssapi/gssapi.h:336: warning: `GSS_S_BAD_NAMETYPE'
redefined
/usr/include/gssapi.h:379: warning: this is the location of the previous
definition
/usr/local/include/gssapi/gssapi.h:337: warning: `GSS_S_BAD_BINDINGS'
redefined
/usr/include/gssapi.h:381: warning: this is the location of the previous
definition
/usr/local/include/gssapi/gssapi.h:338: warning: `GSS_S_BAD_STATUS'
redefined
/usr/include/gssapi.h:382: warning: this is the location of the previous
definition
/usr/local/include/gssapi/gssapi.h:339: warning: `GSS_S_BAD_SIG' redefined
/usr/include/gssapi.h:383: warning: this is the location of the previous
definition
/usr/local/include/gssapi/gssapi.h:340: warning: `GSS_S_NO_CRED' redefined
/usr/include/gssapi.h:385: warning: this is the location of the previous
definition
/usr/local/include/gssapi/gssapi.h:341: warning: `GSS_S_NO_CONTEXT'
redefined
/usr/include/gssapi.h:386: warning: this is the location of the previous
definition
/usr/local/include/gssapi/gssapi.h:342: warning: `GSS_S_DEFECTIVE_TOKEN'
redefined
/usr/include/gssapi.h:387: warning: this is the location of the previous
definition
/usr/local/include/gssapi/gssapi.h:344: warning:
`GSS_S_DEFECTIVE_CREDENTIAL' redefined
/usr/include/gssapi.h:388: warning: this is the location of the previous
definition
/usr/local/include/gssapi/gssapi.h:346: warning:
`GSS_S_CREDENTIALS_EXPIRED' redefined
/usr/include/gssapi.h:389: warning: this is the location of the previous
definition
/usr/local/include/gssapi/gssapi.h:348: warning: `GSS_S_CONTEXT_EXPIRED'
redefined
/usr/include/gssapi.h:390: warning: this is the location of the previous
definition
/usr/local/include/gssapi/gssapi.h:349: warning: `GSS_S_FAILURE' redefined
/usr/include/gssapi.h:391: warning: this is the location of the previous
definition
/usr/local/include/gssapi/gssapi.h:350: warning: `GSS_S_BAD_QOP' redefined
/usr/include/gssapi.h:392: warning: this is the location of the previous
definition
/usr/local/include/gssapi/gssapi.h:351: warning: `GSS_S_UNAUTHORIZED'
redefined
/usr/include/gssapi.h:393: warning: this is the location of the previous
definition
/usr/local/include/gssapi/gssapi.h:352: warning: `GSS_S_UNAVAILABLE'
redefined
/usr/include/gssapi.h:394: warning: this is the location of the previous
definition
/usr/local/include/gssapi/gssapi.h:354: warning: `GSS_S_DUPLICATE_ELEMENT'
redefined
/usr/include/gssapi.h:395: warning: this is the location of the previous
definition
/usr/local/include/gssapi/gssapi.h:356: warning: `GSS_S_NAME_NOT_MN'
redefined
/usr/include/gssapi.h:396: warning: this is the location of the previous
definition
/usr/local/include/gssapi/gssapi.h:361: warning: `GSS_S_CONTINUE_NEEDED'
redefined
/usr/include/gssapi.h:401: warning: this is the location of the previous
definition
/usr/local/include/gssapi/gssapi.h:362: warning: `GSS_S_DUPLICATE_TOKEN'
redefined
/usr/include/gssapi.h:402: warning: this is the location of the previous
definition
/usr/local/include/gssapi/gssapi.h:363: warning: `GSS_S_OLD_TOKEN'
redefined
/usr/include/gssapi.h:403: warning: this is the location of the previous
definition
/usr/local/include/gssapi/gssapi.h:364: warning: `GSS_S_UNSEQ_TOKEN'
redefined
/usr/include/gssapi.h:404: warning: this is the location of the previous
definition
/usr/local/include/gssapi/gssapi.h:365: warning: `GSS_S_GAP_TOKEN'
redefined
/usr/include/gssapi.h:405: warning: this is the location of the previous
definition
In file included from include/includes.h:429,
                 from dynconfig.c:21:
/usr/local/include/gssapi/gssapi.h:137: conflicting types for `gss_name_t'
/usr/include/gssapi.h:70: previous declaration of `gss_name_t'
/usr/local/include/gssapi/gssapi.h:138: conflicting types for
`gss_cred_id_t'
/usr/include/gssapi.h:107: previous declaration of `gss_cred_id_t'
/usr/local/include/gssapi/gssapi.h:139: conflicting types for
`gss_ctx_id_t'
/usr/include/gssapi.h:80: previous declaration of `gss_ctx_id_t'
/usr/local/include/gssapi/gssapi.h:149: redefinition of `gss_uint32'
/usr/include/gssapi.h:58: `gss_uint32' previously declared here
/usr/local/include/gssapi/gssapi.h:166: redefinition of `OM_uint32'
/usr/include/gssapi.h:56: `OM_uint32' previously declared here
/usr/local/include/gssapi/gssapi.h:168: redefinition of `struct
gss_OID_desc_struct'
/usr/local/include/gssapi/gssapi.h:171: redefinition of `gss_OID_desc'
/usr/include/gssapi.h:85: `gss_OID_desc' previously declared here
/usr/local/include/gssapi/gssapi.h:171: redefinition of `gss_OID'
/usr/include/gssapi.h:85: `gss_OID' previously declared here
/usr/local/include/gssapi/gssapi.h:174: redefinition of `struct
gss_OID_set_desc_struct'
/usr/local/include/gssapi/gssapi.h:177: redefinition of `gss_OID_set_desc'
/usr/include/gssapi.h:90: `gss_OID_set_desc' previously declared here
/usr/local/include/gssapi/gssapi.h:177: redefinition of `gss_OID_set'
/usr/include/gssapi.h:90: `gss_OID_set' previously declared here
/usr/local/include/gssapi/gssapi.h:179: redefinition of `struct
gss_buffer_desc_struct'
/usr/local/include/gssapi/gssapi.h:182: redefinition of `gss_buffer_desc'
/usr/include/gssapi.h:112: `gss_buffer_desc' previously declared here
/usr/local/include/gssapi/gssapi.h:182: redefinition of `gss_buffer_t'
/usr/include/gssapi.h:112: `gss_buffer_t' previously declared here
/usr/local/include/gssapi/gssapi.h:184: redefinition of `struct
gss_channel_bindings_struct'
/usr/local/include/gssapi/gssapi.h:190: redefinition of
`gss_channel_bindings_t'
/usr/include/gssapi.h:120: `gss_channel_bindings_t' previously declared
here
/usr/local/include/gssapi/gssapi.h:196: redefinition of `gss_qop_t'
/usr/include/gssapi.h:125: `gss_qop_t' previously declared here
/usr/local/include/gssapi/gssapi.h:197: redefinition of `gss_cred_usage_t'
/usr/include/gssapi.h:96: `gss_cred_usage_t' previously declared here
/usr/local/include/gssapi/gssapi.h:482: conflicting types for
`gss_acquire_cred'
/usr/include/gssapi.h:466: previous declaration of `gss_acquire_cred'
/usr/local/include/gssapi/gssapi.h:487: conflicting types for
`gss_release_cred'
/usr/include/gssapi.h:471: previous declaration of `gss_release_cred'
/usr/local/include/gssapi/gssapi.h:503: conflicting types for
`gss_init_sec_context'
/usr/include/gssapi.h:487: previous declaration of `gss_init_sec_context'
/usr/local/include/gssapi/gssapi.h:517: conflicting types for
`gss_accept_sec_context'
/usr/include/gssapi.h:501: previous declaration of
`gss_accept_sec_context'
/usr/local/include/gssapi/gssapi.h:523: conflicting types for
`gss_process_context_token'
/usr/include/gssapi.h:507: previous declaration of
`gss_process_context_token'
/usr/local/include/gssapi/gssapi.h:529: conflicting types for
`gss_delete_sec_context'
/usr/include/gssapi.h:513: previous declaration of
`gss_delete_sec_context'
/usr/local/include/gssapi/gssapi.h:535: conflicting types for
`gss_context_time'
/usr/include/gssapi.h:519: previous declaration of `gss_context_time'
/usr/local/include/gssapi/gssapi.h:544: conflicting types for
`gss_get_mic'
/usr/include/gssapi.h:527: previous declaration of `gss_get_mic'
/usr/local/include/gssapi/gssapi.h:553: conflicting types for
`gss_verify_mic'
/usr/include/gssapi.h:535: previous declaration of `gss_verify_mic'
/usr/local/include/gssapi/gssapi.h:564: conflicting types for `gss_wrap'
/usr/include/gssapi.h:545: previous declaration of `gss_wrap'
/usr/local/include/gssapi/gssapi.h:574: conflicting types for `gss_unwrap'
/usr/include/gssapi.h:554: previous declaration of `gss_unwrap'
/usr/local/include/gssapi/gssapi.h:595: conflicting types for
`gss_compare_name'
/usr/include/gssapi.h:575: previous declaration of `gss_compare_name'
/usr/local/include/gssapi/gssapi.h:602: conflicting types for
`gss_display_name'
/usr/include/gssapi.h:582: previous declaration of `gss_display_name'
/usr/local/include/gssapi/gssapi.h:609: conflicting types for
`gss_import_name'
/usr/include/gssapi.h:589: previous declaration of `gss_import_name'
/usr/local/include/gssapi/gssapi.h:614: conflicting types for
`gss_release_name'
/usr/include/gssapi.h:600: previous declaration of `gss_release_name'
/usr/local/include/gssapi/gssapi.h:633: conflicting types for
`gss_inquire_cred'
/usr/include/gssapi.h:619: previous declaration of `gss_inquire_cred'
/usr/local/include/gssapi/gssapi.h:646: conflicting types for
`gss_inquire_context'
/usr/include/gssapi.h:631: previous declaration of `gss_inquire_context'
/usr/local/include/gssapi/gssapi.h:656: conflicting types for
`gss_wrap_size_limit'
/usr/include/gssapi.h:640: previous declaration of `gss_wrap_size_limit'
/usr/local/include/gssapi/gssapi.h:687: conflicting types for
`gss_add_cred'
/usr/include/gssapi.h:654: previous declaration of `gss_add_cred'
/usr/local/include/gssapi/gssapi.h:698: conflicting types for
`gss_inquire_cred_by_mech'
/usr/include/gssapi.h:664: previous declaration of
`gss_inquire_cred_by_mech'
/usr/local/include/gssapi/gssapi.h:705: conflicting types for
`gss_export_sec_context'
/usr/include/gssapi.h:670: previous declaration of
`gss_export_sec_context'
/usr/local/include/gssapi/gssapi.h:712: conflicting types for
`gss_import_sec_context'
/usr/include/gssapi.h:676: previous declaration of
`gss_import_sec_context'
/usr/local/include/gssapi/gssapi.h:775: conflicting types for `gss_sign'
/usr/include/gssapi.h:738: previous declaration of `gss_sign'
/usr/local/include/gssapi/gssapi.h:783: conflicting types for `gss_verify'
/usr/include/gssapi.h:746: previous declaration of `gss_verify'
/usr/local/include/gssapi/gssapi.h:793: conflicting types for `gss_seal'
/usr/include/gssapi.h:756: previous declaration of `gss_seal'
/usr/local/include/gssapi/gssapi.h:802: conflicting types for `gss_unseal'
/usr/include/gssapi.h:765: previous declaration of `gss_unseal'
/usr/local/include/gssapi/gssapi.h:809: conflicting types for
`gss_export_name'
/usr/include/gssapi.h:595: previous declaration of `gss_export_name'
/usr/local/include/gssapi/gssapi.h:816: conflicting types for
`gss_duplicate_name'
/usr/include/gssapi.h:719: previous declaration of `gss_duplicate_name'
/usr/local/include/gssapi/gssapi.h:824: conflicting types for
`gss_canonicalize_name'
/usr/include/gssapi.h:713: previous declaration of `gss_canonicalize_name'
*** Error code 1

Stop in /usr/ports/net/samba-devel/work/samba-3.0.0beta1/source.
*** Error code 1

Stop in /usr/ports/net/samba-devel.


My apologies for the long paste.  I get this error on 4.8 stable and
5.1-CURRENT boxes: nothing will build the new samba through portupgrade or
just a simple make clean && make build

Has anyomne else seen this problem or is it just my own personal Server
Message Block demons out for my soul.

Tim Kellers
CPE/NJIT

_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to