I'm having quite a problem trying to get MPlayer to display TV on FreeBSD 4.7. When I try to play it, I get nothing but a blue window. When I try to encode/dump it, MPlayer/Mencoder exit with an error of: "Couldn't find matching colorspace - retrying with -vop scale..." "Sorry, selected video_out device is incompatible with this codec." "Can't find codec matching selected -vo and video format 0x59565955!" and "Exiting..."

I can assure everyone that there is no videocard problem. I have tried two different AGP cards (ATI Rage128 and Nvidia GeForce4), and XV, SDL, GL, etc, all work perfectly for anything other than TV-viewing. Besides, a videocard problem wouldn't account for my inability to record/encode.

I have /modules/bktr_mem.o and bktr.o loading at startup, and FXTV works quite well with it. I've had it working fine under a couple different Linux 2.4.xx distros with Mplayer, albeit using v4l, not bktr.

I have gone so far as to having written a script that tried every possible combination of "hw.bt848.card=" and "hw.bt848.tuner=", and trying to get mplayer to encode a few seconds of video using each setting. That just leaves me with a buch of 0B output files.

The card in question is a K-World "KW-TV878RF-PRO". My DMESG is below. The command-line I typically use to launch mplayer is: "mplayer -tv on:driver=bsdbt848:input=0:width=640:height=480:norm=NTSC:chanlist=us-cable:channel=11", although I've tried plenty of minor variations by now, such as trying all the different "outfmt=" settings, etc.

This is something I really need to be able to do, but this has been quite a stumbling block so far. It doesn't help that every result I find searching through google is someone saying how well MPlayer works at displaying TV (D'oh!). If nobody has any aswers, I suppose I'll have to go bother the port maintainer with this one, which I'd rather not do... Any help is appreciated.


Copyright (c) 1992-2002 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD 4.7-RELEASE #0: Fri Jul  4 03:11:01 PDT 2003
    [EMAIL PROTECTED]:/usr/src/sys/compile/GENERIC
Timecounter "i8254"  frequency 1193182 Hz
CPU: AMD Athlon(TM) XP 2000+ (1666.74-MHz 686-class CPU)
  Origin = "AuthenticAMD"  Id = 0x681  Stepping = 1

AMD Features=0xc0400000<AMIE,DSP,3DNow!>
real memory = 268419072 (262128K bytes)
avail memory = 253861888 (247912K bytes)
Preloaded elf kernel "kernel" at 0xc071b000.
Preloaded elf module "linux.ko" at 0xc071b09c.
Pentium Pro MTRR support enabled
md0: Malloc disk
Using $PIR table, 9 entries at 0xc00f1f10
npx0: <math processor> on motherboard
npx0: INT 16 interface
pcib0: <Host to PCI bridge> on motherboard
pci0: <PCI bus> on pcib0
pcib2: <PCI to PCI bridge (vendor=1039 device=0001)> at device 1.0 on pci0
pci1: <PCI bus> on pcib2
pci1: <ATI model 5046 graphics accelerator> at 0.0 irq 11
isab0: <PCI to ISA bridge (vendor=1039 device=0018)> at device 2.0 on pci0
isa0: <ISA bus> on isab0
ohci0: <SiS 5571 USB controller> mem 0xef000000-0xef000fff irq 9 at device 2.2 on pci0
usb0: OHCI version 1.0, legacy support
usb0: SMM does not respond, resetting
usb0: <SiS 5571 USB controller> on ohci0
usb0: USB revision 1.0
uhub0: SiS OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 3 ports with 3 removable, self powered
ums0: Logitech USB-PS/2 Optical Mouse, rev 2.00/11.00, addr 2, iclass 3/1
ums0: 3 buttons and Z dir.
ohci1: <SiS 5571 USB controller> mem 0xee800000-0xee800fff irq 9 at device 2.3 on pci0
usb1: OHCI version 1.0, legacy support
usb1: SMM does not respond, resetting
usb1: <SiS 5571 USB controller> on ohci1
usb1: USB revision 1.0
uhub1: SiS OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 3 ports with 3 removable, self powered
atapci0: <SiS 5591 ATA100 controller> port 0xb800-0xb80f at device 2.5 on pci0
ata0: at 0x1f0 irq 14 on atapci0
ata1: at 0x170 irq 15 on atapci0
pci0: <unknown card> (vendor=0x13f6, dev=0x0111) at 5.0 irq 10
pci0: <unknown card> (vendor=0x1102, dev=0x0002) at 9.0 irq 10
pci0: <unknown card> (vendor=0x1102, dev=0x7002) at 9.1
pci0: <unknown card> (vendor=0x109e, dev=0x036e) at 10.0 irq 5
pci0: <unknown card> (vendor=0x109e, dev=0x0878) at 10.1 irq 5
dc0: <ADMtek AN985 10/100BaseTX> port 0x9000-0x90ff mem 0xee000000-0xee0003ff irq 9 at device 11.0 on pci0
dc0: Ethernet address: 08:00:08:00:08:00
miibus0: <MII bus> on dc0
ukphy0: <Generic IEEE 802.3u media interface> on miibus0
ukphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
pcib1: <SiS 5591 host to AGP bridge> on motherboard
pci2: <PCI bus> on pcib1
orm0: <Option ROMs> at iomem 0xc0000-0xcbfff,0xcc000-0xcffff on isa0
fdc0: <NEC 72065B or clone> at port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on isa0
fdc0: FIFO enabled, 8 bytes threshold
fd0: <1440-KB 3.5" drive> on fdc0 drive 0
atkbdc0: <Keyboard controller (i8042)> at port 0x60,0x64 on isa0
atkbd0: <AT Keyboard> flags 0x1 irq 1 on atkbdc0
kbd0 at atkbd0
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
sio0: type 16550A
sio1 at port 0x2f8-0x2ff irq 3 on isa0
sio1: type 16550A
ppc0: <Parallel port> at port 0x378-0x37f irq 7 on isa0
ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/16 bytes threshold
plip0: <PLIP network interface> on ppbus0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
ad0: 26059MB <Maxtor 92732U8> [52946/16/63] at ata0-master UDMA66
acd0: DVD-ROM <Pioneer DVD-ROM ATAPIModel DVD-106S 0122> at ata1-master PIO4
acd1: CD-RW <SONY CD-RW CRX195E1> at ata1-slave PIO4
Mounting root from ufs:/dev/ad0s1a
pcm0: <Creative EMU10K1> port 0x9800-0x981f irq 10 at device 9.0 on pci0
bktr_mem: memory holder loaded
bktr0: <BrookTree 878> mem 0xf7000000-0xf7000fff irq 5 at device 10.0 on pci0
bktr0: Card has no configuration EEPROM. Cannot determine card make.
bktr0: Pinnacle/Miro TV, Temic NTSC tuner.

_______________________________________________ [EMAIL PROTECTED] mailing list http://lists.freebsd.org/mailman/listinfo/freebsd-questions To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to