Paul Chvostek wrote:

On Mon, Jul 07, 2003 at 01:38:59PM -0500, Michael L. Squires wrote:

I've got a box on which 5.0-RELEASE was installed. I updated the source
tree using cvsup to RELENG_5_1 and tried to recompile, and now every

RELENG_5_1 is compiling for me (as of 7/4).

Okay, but it's not for me.

Are you running

mergemaster -p
make buildworld

This is where it stops, while trying to compile bin/cat. The pertinent lines remain:

| /usr/obj/var/src/i386/usr/lib/libc.a(atexit.o): In function `atexit':
| atexit.o(.text+0xc7): undefined reference to `_pthread_mutex_unlock'
| atexit.o(.text+0xd8): undefined reference to `_pthread_mutex_lock'

I tried installing devel/pth from ports, to no avail (which makes sense;
the port wouldn't affect how libc.a has been compiled).

My /etc/make.conf includes:

 CFLAGS= -O3 -pipe

Try CFLAGS= -O2 -pipe


For compiling kernel not recomended turn on optimizing -O2.
I have similar error when make buildworld with -O3.


 COPTFLAGS= -O3 -pipe
 MAKE_IDEA=      YES     # IDEA (128 bit symmetric encryption)
 COMPAT4X=       yes

Any further wisdom?

[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to