I can't get VPOPMAIL authentication to build with the latest port of
/usr/ports/mail/courier-imap/.  Several weeks ago I could with an older
version, but I can't reproduce this.  I've tried modifying the configure
arguments in the Makefile, and everything else I can think of.  Maybe
somebody has some ideas.  -- Should I email the ports list?

I do this:
cd /usr/ports/mail/courier-imap
make clean
make WITH_VPOPMAIL=yes all install

And off it goes...during the build process I see this flash up, which
indicates to that the configure arguments are ok.  Looks like
"--with-authvchkpw" is working.
configure: running /bin/sh './configure' --prefix=/usr/local
'--without-authshadow' '--sysconfdir=/usr/local/etc/courier-imap'
'--enable-workarounds-for-imap-client-bugs' '--enable-unicode'
'--disable-root-check' '--with-authvchkpw' '--without-authldap'
'--without-authmysql' '--without-authpgsql' '--with-authpam'
'--without-authcram' '--prefix=/usr/local'
'--build=i386-portbld-freebsd4.8' 'LDFLAGS=-I/usr/local/lib/mysql'
'CFLAGS=-O -pipe -march=pentiumpro'
'build_alias=i386-portbld-freebsd4.8' 'CC=cc'
--with-mailuser=root --without-socks
--with-authchangepwdir=/var/tmp/dev/null --with-package=courier-imap
--with-version=2.0.0 --cache-file=/dev/null --srcdir=.

However, when it finishes without complaint there is no "authvchkpw"
authentication program.
qmail# ls /usr/local/libexec/courier-imap/authlib/
authdaemon              authdaemond             authdaemond.plain

Several weeks ago with version 1.7.0 I did manage to get it to work, but
I can't reproduce it.  I did save my original Makefile, and tried
rolling the port back to 1.7 but it still won't build.

Here's the authentication daemons I got to build last time.  These are
what I want.
qmail# pwd
qmail# ll
total 544
-rwxr-xr-x  1 root  wheel   85093 Jun 24 17:45 authcustom
-r-xr-xr-x  1 root  wheel   15672 Jun 19 11:06 authdaemon
-rwxr-xr-x  1 root  wheel     408 Jun 19 11:06 authdaemond
-r-xr-xr-x  1 root  wheel   68572 Jun 19 11:06 authdaemond.plain
-rwxr-xr-x  1 root  wheel   59973 Jun 24 17:45 authpam
-rwxr-xr-x  1 root  wheel  116737 Jun 24 17:45 authuserdb
-rwxr-xr-x  1 root  wheel  181293 Jun 24 17:45 authvchkpw



[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to