On Wed, 9 Jul 2003, Thomas Chaffic Mowad wrote:

> Someone thought that the kernel might need more memory so we tried
> increasing VM_KMEM_MAXSIZE too 500 megs and then that caused a panic when
> we booted up.
> So we're kinda stuck here and any help would be greatly appreciated.
> Thanks,
> --Tom Mowad

Have you tried increasing KVA_PAGES?

# Change the size of the kernel virtual address space.  Due to
# constraints in loader(8) on i386, this must be a multiple of 4.
# 256 = 1 GB of kernel address space.  Increasing this also causes
# a reduction of the address space in user processes.  512 splits
# the 4GB cpu address space in half (2GB user, 2GB kernel).
options         KVA_PAGES=260

If that doesn't help, you may also consider trying 4.8-RELEASE or -STABLE;
I believe that some additional changes to fix handling of 4GB machines
were committed after 4.7-RELEASE.  (You'll have to search the mailinglist
archives to confirm this, I can't remember exactly when they occured.)

Also, how are you exhausting 128K sockets to do a test of 2000
simultaneous connections?  Are the rest all in the TIME_WAIT state?

Mike "Silby" Silbersack
[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to