----- Original Message ----- 
From: "Gregory Norman" <[EMAIL PROTECTED]>
Sent: Saturday, July 12, 2003 12:35 PM

> Hello
> I'm trying to upgrade from 4.4 Release to 4.8 Stable. Everything goes
> well until I reboot after building and installing my custom kernel.
> machine is a gateway, nat, ipfw. I will also install MySQL, Apache,
> PHP4 after upgrading.  Prior to upgrading everything worked fine.
> When I reboot it hangs after:
> ppi0: <Parallel I/O> on ppbus0
> I have a copy of my previous kernel and can boot up using it.
> Here is a snippet of the probe showing where it fails:
> sio at port 0x2f8-0x2ff irq 3 on isa 0
> sio1:type 16550a
> ppc0:<Parallel port> at port 0x378-0x37f irq 7 on isa0
> ppc0: Generic chipset (NIBBLE-only) in COMPATIBLE mode
> lpt0:<Printer> on ppbus 0
> lpt0:Interrupt-driven por
> ppi0:<Parallel I/O> on ppbus0 #it hangs here and fail.
> It seem as though the probe fail while searching for dummynet. After
> ppi0:<Parallel I/O> on ppbus0 during a successful boot system probe
> DUMMYNET initialized (xxxxxx)
> IP packet filtering initialized, divert enabled, rule-based forwarding
> disabled,.....
> According to UPDATING there were changes made with dummynet, bridging
> and ipfw  between 4.4 Release and 4.8 Stable. I tried commenting
> dummynet and bridging in my custom kernel, rebuilding and installing
> kernel with those changes. A 4.8 Stable boot still fail at the same
> place.
> A kernel with ppi0<Parallel I/O> on ppbus0 disabled does not work
> either. I have not been able to find a solution by searching google,
> FreeBSD.org either. I have reinstalled the entire OS, starting from a
> clean install of 4.4 Release, still no success.
> Any help, suggestion, pointers, or ideas would be appreciated.

This is a long shot but by chance did you make any changes in your BIOS
between upgrades?  The reason I ask is because I spent the better part
of two weeks wrestling with a machine of my own for this reason.  My
particular case was with a disk drive.  I had set the BIOS to
auto-detect the drive mode instead of manually setting PIO mode.  It
wasn't until I did an upgrade that I had problems.  One of my drives was
detected as WDMA2 in the new kernel but time out, probably because the
drive is so old it doesn't support it.  It would retry a couple of times
and then the system would panic and reboot.  Because it contained my
/usr, the system was useless.  But I could still boot with the old
kernel and this is what stumped me.  I thought that if it was a BIOS
setting, it wouldn't matter what kernel I used.  Anyway, to make a long
story short, manually setting the BIOS to PIO4 mode solved the problem.

Just a thought.  I know what it's like to be totally stumped and have no
idea where to turn.  Good Luck!!!

[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to