Karel J. Bosschaart wrote:
On Sat, Jul 05, 2003 at 07:33:22PM +0200, Bill Moran wrote:


I may be asking for too much ... but has anyone gotten the Linux version
of America's Army Operations running on FreeBSD?

Heh, yes, I just completed Basic Combat Training :-).

It installs nicely, and tries to start, but then complains that it can't
find OpenGL (I have Mesa installed).

I tried with the nvidia driver (from ports) and a GForce Ti4200 card. Setting __GL_SINGLE_THREADED=1 is necessary or the game won't start.
I don't know if the game can be played with other cards (UT2003 for example
can only be played with nvidia on Linux/FreeBSD).

Hmmm ... I tried to install it on a basic vid card with the SVGA driver for X. The more I think about it, I don't know why I expected it to work at all.

Any success stories, or anyone interested in working with me to get this

It feels flaky: I had it hang a couple of times while loading a mission, and sometimes it's crashing, either on start or on exit with a Backtrace:

Doesn't sound bad to me. It tends to do that on Windows, which is the platform it was designed for. Although the actual frequency of crashes may be more.

Backtrace: [ 1] ./Core.so [0x288dc34a] [ 2] /lib/libpthread.so.0 [0x28cb05eb] [ 3] [0xbfbfffbf] [ 4] /lib/libc.so.6(__libc_free+0xb0) [0x28ae2fc0] [ 5] ./armyops-bin(Realloc__11FMallocAnsiPvUiPCw+0x3d) [0x805297d] [ 6] ./Core.so(Realloc__6FArrayi+0x3a) [0x28895d6a] [ 7] ./Core.so(Remove__6FArrayiii+0x8a) [0x28895e06] [ 8] ./Engine.so(_._11AnalogTrack+0x91) [0x285683d5] [ 9] ./Engine.so(_._11MotionChunk+0xb1) [0x28568b15] [10] ./Engine.so(_._14UMeshAnimation+0x18e) [0x2856cc22] [11] ./Core.so(PurgeGarbage__7UObject+0x19f) [0x288b7b13] [12] ./Core.so(StaticExit__7UObject+0x1c8) [0x288ab270] [13] ./Core.so(appPreExit__Fv+0x4b) [0x288a023f] [14] ./armyops-bin(main+0x2709) [0x8050a79] [15] /lib/libc.so.6(__libc_start_main+0x8e) [0x28a82336] [16] ./armyops-bin(GetFullName__C7UObjectPw+0x5d) [0x804c6e1] Signal: SIGSEGV [segmentation fault]

Also, there are these messages:

fcntl: Invalid argument
fcntl: Invalid argument
Xlib:  extension "XiG-SUNDRY-NONSTANDARD" missing on display ":0.0".
fcntl: Invalid argument

but I think they're harmless.

I'm trying to install on 5.1 at the moment ...

Tried this on 4.8-stable. Having remote access to the machine is recommended
to 'kill -9' when it misbehaves.

Thanks, but now that I'm looking at the situation again, I'm guessing I'm going to have to get a better video card before I've got any chance of it working, and (with my current work outlook) it may be a while before I dump any cash into a gaming video card.

Bill Moran
Potential Technologies

[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to