>> They're brand new cables, from promise, and I don't have this problem
under linux (I get over 40 MB/s transfer rate with hdparm).  However, I will
try other cables eventually.  If anyone has another idea, please let me
know. Thanks,

Sorry for the double-post, i didn't know how to reply directly to a post.
Hope this one works out.

Try getting new cables. I have had a similar problem caused by bad cables

On Thu, 24 Jul 2003 22:57:48 -0400 (EDT)
Ugo Bellavance <iolubik at yahoo.ca> wrote:

> Hi,
> --System
> FreeBSD 4.8 release
> It is a kernel that I recompiled only to enable SMP.
> The same error comes with the generic stock generic
> Kernel.
> It is a dual Athlon MP 1800+ on a tyan MB.  The Raid
> card is a TX-2000 with 2 Hot swap superswap enclosure.
>  The only other IDE device, the cd-rom is on the IDE
> controller on the motherboard.  The raid is a RAID1
> with 2 Western Digital 80 Gb, 8 Mb cache, 7200rpm,
> each of them is ont a separate channel.  I checked the
> cable and they are connected on the right side.  I
> even tried to put them the other way around and I get
> the same error message.
> --Problem: FreeBSD only puts my drive in udma33 while
> the Motherboard, cables, enclosures and drives support
> udma100.  I don't know if it is a bogus error, because
> I don't know how to test it (like hdparm in linux).
> --Other data:
> output from dmesg
> atapci1: <Promise TX2 ATA133 controller> port
> 0x1010-0x101f,0x1024-0x1027,0x1028-0x102f,0x1030-0x1033,0x1038-0x103f
> mem 0xf0000000-0xf000ffff irq 2 at device 8.0 on pci0
> ad4: DMA limited to UDMA33, non-ATA66 cable or device
> ad6: DMA limited to UDMA33, non-ATA66 cable or device
> ar0: 1907348MB <ATA RAID1 array> [65535/255/63]
> status: READY subdisks:
>  0 READY ad4: 76319MB <WDC WD800JB-00CRA1>
> [155061/16/63] at ata2-master UDMA33
>          ad4: SuperSwap enclosure [FAN:4218rpm
> TEMP:28.0C 5.022V 12.078V]
>  1 READY ad6: 76319MB <WDC WD800JB-00CRA1>
> [155061/16/63] at ata3-master UDMA33
>          ad6: SuperSwap enclosure [FAN:4166rpm
> TEMP:28.0C 4.941V 11.895V]
> Jul 24 21:16:08 bibi /kernel: acd0: CDROM <HL-DT-ST
> CD-ROM GCR-8520B> at ata1-master PIO4
> output of atacontrol list
>  atacontrol list
> ATA channel 0:
>     Master:      no device present
>     Slave:       no device present
> ATA channel 1:
>     Master: acd0 <HL-DT-ST CD-ROM GCR-8520B/1.00>
> ATA/ATAPI rev 0
>     Slave:       no device present
> ATA channel 2:
>     Master:  ad4 <WDC WD800JB-00CRA1/17.07W17>
> ATA/ATAPI rev 5
>     Slave:       no device present
> ATA channel 3:
>     Master:  ad6 <WDC WD800JB-00CRA1/17.07W17>
> ATA/ATAPI rev 5
>     Slave:       no device present
> Nothing interesting in /var/log/messages
> Other logs can be provided upon request.  I just don't
> want to make the post too long.
> Thanks for your help.
> Ugo Bellavance

[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to