On Sunday, 27 July 2003 at 19:15:57 -0700, Karl Agee wrote:
> At 11:10 AM 7/27/2003 +0930, you wrote:
>
>> On Thursday, 24 July 2003 at 21:47:23 -0700, Karl Agee wrote:
>>> I am having problems getting X set up properly on a laptop.  Should
>>> I post the question here or on the mobile list?
>>
>> Start here, but give some details.  If this is a Dell Inspiron 5100,
>> I'm working on it.
>
> Hi Greg and all:

You forgot to copy "and all".  I'm doing it now.

> Laptop:  Thinkpad iSeries 1300
> Video:  Silicon Motion LynxEM+ chip
> Screen:  800x600 hpa
>
> system:  FreeBSD 4.8-RELEASE
>
> Only the vga driver works, and not very well.  Gives me only a 640x480
> display and the windows etc are not displayed properly (too large for the
> display).

That's a window manager issue.

> This setup was configured using either xf86config or xf86cfg
> -textmode.  Using the "autodetect" selection froze the display, as
> does trying to setup manually using the above and the silicon motion
> driver.  Killing X server doesnt work, have to reboot the machine.

Hmm.  Anything unusual in /var/log/XFree86.0.log?  I had this recently:
   
   (==) RADEON(0): Write-combining range (0xc0000,0x40000) was already clear
   (WW) RADEON(0): Bad V_BIOS checksum
   (II) RADEON(0): Primary V_BIOS segment is: 0xc000
   (==) RADEON(0): Write-combining range (0x0,0x1000) was already clear   
   (--) RADEON(0): Chipset: "ATI Radeon Mobility M7 LW (AGP)" (ChipID = 0x4c57)
   (--) RADEON(0): Linear framebuffer at 0xf0000000
   (--) RADEON(0): MMIO registers at 0xe0100000
   (==) RADEON(0): Write-combining range (0xe0100000,0x80000) was already clear
   (--) RADEON(0): VideoRAM: 16384 kByte (64-bit DDR SDRAM)
   (==) RADEON(0): Write-combining range (0xe0100000,0x80000) was already clear
   (II) RADEON(0): CloneDisplay option not set -- defaulting to auto-detect
   (II) RADEON(0): Primary Display == Type 2
   (II) RADEON(0): Panel ID string: 
   (II) RADEON(0): Panel Size from BIOS: 65535x65535
   
      *** If unresolved symbols were reported above, they might not
      *** be the reason for the server aborting.
   
   Fatal server error:
   Caught signal 11.  Server aborting

This was on a Dell Inspiron 5100, and it's caused by incorrect mapping
of the video BIOS.  It would be interesting to see if you're having a
similar problem. 

> This notebook works fine with suse 8.1, Red Hat 9, Knoppix 3.1, etc.

I also tried my laptop with Knoppix 3.1, and it worked fine.  It's
obviously a FreeBSD problem, and I'm currently trying to localize it.

> I did notice the XF86Config file is the old XFree 3.x series format,
> apparently not the newer series 4.x format.  (dont know if that is
> significant).

Depends on where it came from.  The log file is more interesting, and
it'll tell you which of the myriad possible config files it uses.

Greg
--
Finger [EMAIL PROTECTED] for PGP public key
See complete headers for address and phone numbers

Attachment: pgp00000.pgp
Description: PGP signature

Reply via email to