I have been unable to run an X client+server on 4.8 release for several
weeks due to what appears to be a known issue.  The problem surfaced a 
few days after my weekly port upgrade (none of the upgrades were X 
related - the previous weeks upgrade did update an X port, but I'm not
certain which).

Google found two similar issues, one appears to be due to using -O2
optimisation with gcc3.3 to compile freetype on Debian.  The other 
message was in the xfree86 fonts mailing list archive:


  That's expected behaviour with current CVS, which is not internally
  consistent.  Both the freetype and the type1 backends register for
  PostScript fonts; whichever you get depends on the order they 
  register.

  Could you please try again after applying


  http://www.pps.jussieu.fr/~jch/software/files/
    xfree86-fnts-ririt-2002025.tch

  Assuming it works today, it will cause the freetype backend to get
  Type 1 fonts, and the type1 backend to get CFF fonts.


The patch is no longer available, & the author of the above email did 
not respond to a request for more information.  I emailed the maintainer
of freetype2 a couple of weeks ago but have not yet had any response.

Up to now I have used packages for XFree86.  Last week I tried re-
installing X using the ports in a desperate attempt to resolve the 
issue.  I have also tried disabling some of the modules loaded by
/etc/XF86Config-4 to narrow down the problem.

Any suggestions what I should do next?.  Is there anything I can do to 
be more pro-active in resolving this issue, or do I assume that the 
problem is with freetype2 & a patch is in the pipeline?.

thanks
Jeff
_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to