Hi everybody.
Thx for your replies.
First I tried to fix it with the
" entropy harvest stuff " from /etc/defaults/rc.conf, with no luck.
I tried the sysctl command and it went into a loop with ip-filter.
Guessed the problem belonged to my custom kernelbuild, and rebuildt
with GENERIC and the problem went away.
Then I somehow screwed up my X-Configuration and can't log in to KDE.
Think I go back to 4.8 Just wanted to have a look at 5.
I'm to much in the dark with 5.x
Thx a lot everybody for you effort to help.

Best Regards
Geir Svalland.

-----Original Message-----
From: [EMAIL PROTECTED]
[mailto:[EMAIL PROTECTED] Behalf Of Eivind Olsen
Sent: Tuesday, July 29, 2003 9:11 PM
To: [EMAIL PROTECTED]
Subject: Re: 5.1 Hangs on boot


--On 28. juli 2003 16:40 +0200 Hasse <[EMAIL PROTECTED]> wrote:
> Stopping at Entropy harvesting.
> I have to press "CTRL+C" to continue booting.
> Then everything works as it's supposed to. ( I think ? )
> Frankly, I don't have a clue on what I'm doing,
> but I've disabled ACPI in my /boot/device.hints file
> to get my floppy drive to work, and I've commented out all
> SCSI devices exept device scbus, and all Raid in my kernel,
> because I don't have any.

I've had the same thing happen here with RELENG_5_1.
When you have managed to log in, run "sysctl -a" and see if that one also
hangs (it's being run as part of the initrandom-stuff).
If "sysctl -a" hangs too, you might run "top" to see that "sysctl -a"
consumes all your CPU. You can kill sysctl with CTRL-C or a kill-command.

My solution was to go back to the GENERIC kernel and just add the three
IPFILTER-options I needed there. With my custom kernel I'd see this problem.

I saw this problem 2-3 days ago and haven't had time to look deeper into
WHY it's failing (or filing a PR) since I've also had to actually get
FreeBSD installed on that server.

If anyone's interested, here's some information:


When running "sysctl -a" lots of output is shown, but then it hangs. Here
are the last few lines it shows:

[...]
net.inet.ipf.fr_authused: 0
net.inet.ipf.fr_defaultauthage: 600
net.inet.ipf.fr_chksrc: 0
net.inet.ipf.ippr_ftp_pasvonly: 0
net.inet.ipf.fr_minttl: 3
net.inet.ipf.fr_minttllog: 1
^C
vimes#

Compiled sysctl with "DEBUG_FLAGS" set (but they might not be set
correctly), started that sysctl, killed it with "kill -SEGV" when it is
looping to produce sysctl.core:

vimes# gdb sysctl -c sysctl.core
GNU gdb 5.2.1 (FreeBSD)
Copyright 2002 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain
conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-undermydesk-freebsd"...
Core was generated by `sysctl'.
Program terminated with signal 11, Segmentation fault.
#0  0x0805cd1b in __sysctl ()
(gdb) bt
#0  0x0805cd1b in __sysctl ()
#1  0x08052032 in sysctl ()
#2  0x080490af in show_var (oid=0xbfbffb00, nlen=-1077939624) at
/usr/src/sbin/sysctl/sysctl.c:507
#3  0x08049710 in sysctl_all (oid=0x0, len=0) at
/usr/src/sbin/sysctl/sysctl.c:636
#4  0x0804836f in main (argc=0, argv=0xbfbffc28) at
/usr/src/sbin/sysctl/sysctl.c:141
#5  0x08048145 in _start ()
(gdb) quit
vimes#

I have no idea if this is _any_ help to anyone whatsoever.

vimes# uname -a
FreeBSD vimes.eivind 5.1-RELEASE FreeBSD 5.1-RELEASE #0: Sun Jul 27
16:22:34 CEST 2003     [EMAIL PROTECTED]:/usr/obj/usr/src/sys/VIMES  i386
vimes#

I'm tracking RELENG_5_1 and I csvup'ed just a few hours before this
(sometime between 08:00 and 09:00 CET on the 27th of July).

Here's all the stuff I'd left in my VIMES kernel-config:

machine         i386
cpu             I686_CPU
ident           VIMES
options         SCHED_4BSD              #4BSD scheduler
options         INET                    #InterNETworking
options         INET6                   #IPv6 communications protocols
options         FFS                     #Berkeley Fast Filesystem
options         SOFTUPDATES             #Enable FFS soft updates support
options         UFS_ACL                 #Support for access control lists
options         UFS_DIRHASH             #Improve performance on big
directories
options         MD_ROOT                 #MD is a potential root device
options         NFSCLIENT               #Network Filesystem Client
options         NFSSERVER               #Network Filesystem Server
options         NFS_ROOT                #NFS usable as root device,
requires NFSCLIENT
options         MSDOSFS                 #MSDOS Filesystem
options         CD9660                  #ISO 9660 Filesystem
options         PROCFS                  #Process filesystem (requires
PSEUDOFS)
options         PSEUDOFS                #Pseudo-filesystem framework
options         COMPAT_43               #Compatible with BSD 4.3 [KEEP
THIS!]
options         COMPAT_FREEBSD4         #Compatible with FreeBSD4
options         SCSI_DELAY=15000        #Delay (in ms) before probing SCSI
options         KTRACE                  #ktrace(1) support
options         SYSVSHM                 #SYSV-style shared memory
options         SYSVMSG                 #SYSV-style message queues
options         SYSVSEM                 #SYSV-style semaphores
options         _KPOSIX_PRIORITY_SCHEDULING #Posix P1003_1B real-time
extensions
options         KBD_INSTALL_CDEV        # install a CDEV entry in /dev
                                        # output.  Adds ~128k to driver.
                                        # output.  Adds ~215k to driver.
options         DDB                     #Enable the kernel debugger
device          isa
device          pci
device          fdc
device          ata
device          atadisk                 # ATA disk drives
device          atapicd                 # ATAPI CDROM drives
options         ATA_STATIC_ID           #Static device numbering
device          scbus           # SCSI bus (required)
device          atkbdc          # AT keyboard controller
device          atkbd           # AT keyboard
device          psm             # PS/2 mouse
device          vga             # VGA video card driver
device          splash          # Splash screen and screen saver support
device          sc
options         SC_DISABLE_DDBKEY
device          agp             # support several AGP chipsets
device          npx
device          pmtimer
device          sio             # 8250, 16[45]50 based serial ports
device          ppc
device          ppbus           # Parallel port bus (required)
device          lpt             # Printer
device          miibus          # MII bus support
device          fxp             # Intel EtherExpress PRO/100B (82557, 82558)
device          random          # Entropy device
device          loop            # Network loopback
device          ether           # Ethernet support
device          tun             # Packet tunnel.
device          pty             # Pseudo-ttys (telnet etc)
device          md              # Memory "disks"
device          gif             # IPv6 and IPv4 tunneling
device          faith           # IPv6-to-IPv4 relaying (translation)
device          stf
device          bpf             # Berkeley packet filter
options         DEVICE_POLLING
options         HZ=1000
options         DUMMYNET
options         IPFIREWALL
options         IPFIREWALL_VERBOSE
options         IPFIREWALL_FORWARD
options         IPFIREWALL_VERBOSE_LIMIT=100
options         IPV6FIREWALL
options         IPV6FIREWALL_VERBOSE
options         IPV6FIREWALL_VERBOSE_LIMIT=100
options         IPDIVERT
options         IPFILTER
options         IPFILTER_LOG
options         IPFILTER_DEFAULT_BLOCK
options         NETSMB
options         NETSMBCRYPTO
options         LIBMCHAIN
options         LIBICONV
options         QUOTA
options         RANDOM_IP_ID
options         SMBFS
device          snp
makeoptions     ATKBD_DFLT_KEYMAP="norwegian.iso"

I haven't had time to experiment with this kernel config just yet so I'm
not sure exactly what can be wrong.

--
Regards / Hilsen
Eivind Olsen
<[EMAIL PROTECTED]>
_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to