I had the same exact problem.  I traced it to be a bug in some software 
that opened a domain socket(2) but could not connect(2) and never closed
the descriptor returned.

something like:

sd = socket(AF_UNIX, SOCK_STREAM, 0);
...
if(connect(sd, (struct sockaddr *)&saddr, sizeof(saddr)) < 0) {  
   return -1;
}
 
where close(2) was skipped on sd if the connect failed.

over a period of time (12-18hrs), these unconnected sockets would fill
up the available buffer space, and exhibit the same symptoms you are
having. even running ifconfig would fail with No buffer space available.

from intro(2):
55 ENOBUFS No buffer space available.  An operation on a socket or pipe
was not performed because the system lacked sufficient buffer space or
because a queue was full.

Fixing that bug fixed the problem. I doubt you have a hardware problem,
I would try narrowing down what software is causing the lockup. truss(1)
might help you out here.



Dave




On Wed, 2003-07-30 at 09:32, Haesu wrote:
> Hello,
> 
> We have a FreeBSD box here that we use to route some GRE tunnels and ipv6 gif 
> tunnels. We use zebra for dynamic routing running zebra, bgpd, ospfd, and ospf6d.
> 
> We have about 12 FreeBSD boxes with exact same configuration, the only
> difference is just the IP address of each interface.
> 
> None of them fail but this one box...
> 
> Everyday, this box stops all networking. I can still console in and stuff.. When
> I typed 'ping 127.0.0.1' at the console after networking locked up, it says:
> ping: sendto: No buffer space available
> 
> The only solution seems to be rebooting it everyday... It happens every 12 hours
> or so...
> 
> This is not related with mbuf, etc either, as netstat -m doesn't show any
> issues.
> 
> The box has one IP address and IPv6 address in addition to 127.0.0.1 on lo0
> interface. It also has a ds0 interface with 10.5.5.5/30 assigned to ds0.
> This is exact same configuration on all other boxes, and none of them fail but
> this one.
> 
> I've swapped out NICs with different vendors 3 times (tried, xl, dc, and now rl)
> 
> I've also swapped out the whole box, and also swapped out the whole hard drive
> and did full reinstall. And problem still persists and it's definately not
> hardware as I swapped everything out... (unless the 3 NIC vendors above are all
> exhibiting same issue)
> 
> I tried to look on Google but nothing useful that corelates to this particular
> issue..
> 
> Any help would be very appreciated :)
> 
> Thanks,
> -hc
> 
> The box is running FreeBSD 4.8-STABLE
> FreeBSD necsis 4.8-STABLE FreeBSD 4.8-STABLE #0: Tue Jul 29 13:10:11 GMT 2003     
> [EMAIL PROTECTED]:/usr/src/sys/compile/router  i386
> 
> Following is output of netstat -s AFTER the networking locks up with no buffer
> space available error:


_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to