On a FreeBSD 4.3 server (I inherited when I took over IT duties at a new
client), I am getting "Undefined symbol "__stdoutp"" error messages when
I try to run utilities (e.g. sudo) that I have pkg_add'ed to the server.
 Also, attempts to build the latest 'sudo' port fail.  Initially, the
port building failure involved the fact that  /usr/local/bin/sed_inplace
did not exist.  Trying to build that port failed as well... so I
pkg_add'ed sed_inplace... But then the sudo port build kept failing.

Here is an example of the error I get when I try to run sudo:

    > sudo date
    /usr/libexec/ld-elf.so.1: Undefined symbol "__stdoutp" referenced from
COPY relocation in sudo

I tried searching the mailing lists via http://lists.freebsd.org, but
was told the "lists are unavailable at this time"...

I have tried 'google' searches etc.  The best I can figure is that
something changed somewhere along the way in FreeBSD 4.X causing port
builds to fail.  I am also guessing that it _may_ have something to do
with the 'compat' libraries, but this is just a guess.

I see the following "C lib" related compat libraries in /usr/lib/compat:


        Note:  I do _not_ have a /usr/lib/compat/libc.so.4.... should I?

I can generally figure things out on my own... but this has kind of got
me turning in circles... Maybe if someone can just point me in the
correct direction...  or  send me a pointer to a FAQ or HowTo article,
or a simple list of instructions.

After doing some more searching... I'm getting the feeling that I need
to re-build my libraries, which would mean installing the source,
wouldn't it?  If this is correct, I need some instructions or pointers
to instructions in the handbook.

Update:  I have done a 'make' in /usr/src/lib/libc and copied the newly
         created libc.so.4 to /usr/lib/libc.so.4 and changed the permissions
         to 444... but I still get the same Undefined symbol "__stdoutp"

This smells like there has to be a _simple_ fix for this...

Many thanks.

Steve Camp

[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to