[CC'd for anyone who may need this resolution]

Hi Carl,
  Yes, I actually did determine the resolution to the problem. Since I had been 
running the system since 4.7-release, I used the drm-kmod package in the ports tree to 
get the DRI support. An undocumented (as far as I can tell) change from 4.7-stable to 
4.8-stable includes the drm kernel module in the kernel module sources, and the 
drm-kmod port is depricated. If you remove the drm-kmod startup script from 
/usr/local/etc/rc.d, optionaly pkg_delete the drm-kmod package, and rebuild your 
kernel with options drm and agp added, you should have hardware support upon loading 
the new kernel. I've browsed through the UPDATING file from my last source update and 
I've found no mention of this change between 4.7-release and 4.8-release. Does anyone 
know why? (my being dense is a perfectly valid reason)

-Reid

>Hi,
>
>I noticed your post on freebsd.questions about your problems in getting drm 
>acceleration to work under freebsd4.8-stable. You reported an error "Radeon 
>DRI driver expected DRM driver version 1.3.x or newer but got version 1.1.1".
>
>I'm having the same problem. Did you ever find a resolution?
>
>Thanks
>
>____________________________________________________________
>
>Dr. Glen Henshaw                       (202) 767-1196
>Naval Center for Space Technology      [EMAIL PROTECTED]
>U.S. Naval Research Laboratory
>
_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to