Hi,

I am having problems configuring sound for a PnP ISA Sound Blaster 16 under FreeBSD5.1 
with KDE3.1. I have followed the multimedia instructions in the handbook and rebuild 
the kernel with:

device pcm
device sbc

Then, using "grep pcm /var/run/dmesg.boot" it finds "pcm" on "sbc1", and I am able to 
play an audio CD using "cdcontrol". I have also modified my "/etc/sysctl.conf" adding:

sysctl hw.snd.pcm0.vchans=4
sysctl hw.snd.maxautovchans=4

Given that during startup KDE reports that it cannot find "/dev/dsp", I have tried to 
configure the settings of KDE in the control centre under its sound system IO dialog 
to set the custom device to "/dev/dsp0.0" then, "/dev/dsp0.1" and tried to test one of 
the KDE default notification sound, with no success.

I also noted that from the kernel rebuild their are no device files for:

/dev/audio
/dev/midi
/dev/mixer
/dev/music
/dev/sequencer
/dev/pss
/dev/dsp
/dev/dspW

Where the console history (from which I started KDE using startx) reported that KDE 
could not find a number of theses drivers. Noting that the only sound related device 
files are (X = 0 to 3):

/dev/dsp0.X
/dev/dspW0.X

At this stage I am running out of ideas, any help would be greatly appreciated.

Regards
Martin

PS: the console history also reports a broken pipe with a signal 15. I think this is 
unrelated.





_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to