On Sat, 9 Aug 2003 20:11:05 -0500
Dan Nelson <[EMAIL PROTECTED]> wrote:

> 
> Luckily the client packages are small (under 1MB), so it's not a major
> problem if both 3.23 and 4.0 get installed.

These ports are conflicting. that's the problem :)

> Doesn't the port build handle this right?  mysql40-client is listed
> before p5-DBD-mysql in RUN_DEPENDS, so ideally bsd.port.mk should be
> able to build and install the 4.0 client, then just use that for the
> p5-DBD-mysql build.

The ports handles it right, the problem is only in dependencies list.

[EMAIL PROTECTED]|(909)| admin]# pkg_add -r ../All/mysql-server-4.0.14.tbz
Fetching 
ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-current/Latest/../All/mysql-server-4.0.14.tbz...
 Done.
Fetching 
ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-current/Latest/../All/p5-DBI-1.37.tbz...
 Done.
Fetching 
ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-current/Latest/../All/mysql-client-4.0.14.tbz...
 Done.
Fetching 
ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-current/Latest/../All/p5-DBD-mysql-2.1026_1.tbz...
 Done.

all is ok.
Because the port set 4.0 by default :
.if exists(${LOCALBASE}/lib/mysql/libmysqlclient.so.10)
LIB_DEPENDS=    mysqlclient.10:${PORTSDIR}/databases/mysql323-client
.else
.if exists(${LOCALBASE}/lib/mysql/libmysqlclient.so.14)
LIB_DEPENDS=    mysqlclient.14:${PORTSDIR}/databases/mysql41-client
.else
LIB_DEPENDS=    mysqlclient.12:${PORTSDIR}/databases/mysql40-client
.endif
.endif

and now the big question is why index consider MySQL
_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to