FreeBSD 4.8

I setup this server last week and recompiled the kernel to remove unecassary hardware and feature support. That worked without a hitch.

I installed a few other apps (Pine, Vim 6, Squid, and Dans Guardian (Dans was compiled from their source--not from a port).

Today I tried recompiling the kernel yet again to add the following options:

options DIVERT

I used the following command to make the kernel:

make buildkernel KERNCONF=CUSTOM

Everytime I try this it fails. The only difference between CUSTOM and GENERIC are the options and devices I removed and the firewall options I added. However, if I try to build GENERIC it also fails now.

The errors in the syslog are:

(cc), uid 0: exited on signal # (core dumped)
(as), uid 0: exited on signal # (core dumped)

The # is either 1, 4, 10, or 11.

Thinking that something got mucked up in the source I deleted the /usr/src/sys directory and reinstalled it--this also didn't work.

I'm pretty new to kernel tweaking. Does anyone know how I might resolve this problem? The research I've done leads me towards kernel debugging--a feature I can't enable as the kernel won't build.

[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to