I have been trying to get mod_perl and apache to play nicely together and they refuse. I have a couple of problems.

1. I can't build and install mod_perl 1.28. I get and Error 1 when make checks to see if any version is installed. I can then go into work/mod_perl-1.28 and make install, but something else seems to be wrong. I never get it to work with apache if I do that.

[/usr/ports/www/mod_perl]# make install
===> Installing for mod_perl-1.28
===> mod_perl-1.28 depends on file: /usr/local/sbin/apxs - found
===> mod_perl-1.28 depends on file: /usr/local/lib/perl5/site_perl/5.8.0/LWP.pm - found
===> Generating temporary packing list
===> Checking if www/mod_perl already installed
*** Error code 1


Stop in /usr/ports/www/mod_perl.

[/usr/ports/www/mod_perl]# pkg_info | grep mod_perl
mod_perl-1.28       Embeds a Perl interpreter in the Apache server

I get the same error, whether or not it's installed.

2. I can install from the packaged version but it is built against perl 5.005 as best I can tell (I enable perl-status and check in a browser: Embedded Perl version 5.00503 for Apache/1.3.28 (Unix) mod_perl/1.28 DAV/1.0.3 process 12540 ) I'm running 5.8 and I'm not sure that's the best way to proceed.

So ideally, I'd like to install from source through the ports system. As a side note, I have been through my ports/packages database with pkgdb: all seems to be clean, after after a few mismatches were cleaned up. I have also tried portinstall and port_upgrade: no joy there, either.

Any help?


-- Paul Beard <http://paulbeard.no-ip.org/movabletype/> whois -h whois.networksolutions.com ha=pb202

Non-sequiturs make me eat lampshades.

_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to