Hello All,

I'm having a really bad time trying to compile Perl 5.8 with thread support on
FreeBSD 5.1 release on i386. I've tried the port and do a "make -DWITH_THREADS",
but it eventually bombs out with the following error:

cd t && (rm -f perl; /bin/ln -s ../miniperl perl)  &&  ./perl TEST base/*.t
comp/*.t cmd/*.t run/*.t io/*.t op/*.t uni/*.t </dev/tty Out of memory!
*** Error code 1 (ignored)
*** Error code 1 (ignored)
./miniperl -Ilib configpm configpm.tmp
Out of memory!
*** Error code 1

I've tried building it separately from the ports and it does the same thing. I've
tried the WITH_PERL_MALLOC option in the ports but am getting nowhere. There is no
memory shortage on this machine. I've tried the ports that came with 5.1R and the
latest ports, but both result in the same error.

Does anyone have some advice on how to compile Perl 5.8 on FreeBSD 5.1R with
threads. I don't believe I'm doing something wrong here as I compiled the same on
Solaris 8 without problems.

[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to