On Fri, Aug 29, 2003 at 02:33:07PM -0700, Michelle wrote:
> I ran mysqldump -A > backup-file.sql and then upgraded the mysql port, 
> but now when I try to restore the backups using mysql "database name"  
> < backup-file.sql, It states unknown database.

I've never had a mysql upgrade trash my databases, but it sounds like
the simple solution is to 'mysqladmin create "database name"' first.
Though the -A does seem to put create database commands in the dump file.
You might look at the sql and find out what's broken...

I tried dumping all mine, and got a "client out of memory" error.  Weird.

-- 
Alan Batie                   ______    alan.batie.org                Me
alan at batie.org            \    /    www.qrd.org         The Triangle
PGPFP DE 3C 29 17 C0 49 7A    \  /     www.pgpi.com   The Weird Numbers
27 40 A5 3C 37 4A DA 52 B9     \/      spamassassin.taint.org  NO SPAM!

To announce that there must be no criticism of the President, or that we
are to stand by the President, right or wrong, is not only unpatriotic
and servile, but is morally treasonable to the American public.
-Theodore Roosevelt, 26th US President (1858-1919)

Attachment: pgp00000.pgp
Description: PGP signature

Reply via email to