Quoting Colin Ryan <[EMAIL PROTECTED]>:

> I have a small network of three computers in my office here.  Two Windows
> 2000, and one FreeBSD 5.1.  It's the BSD box that's giving me problems.
> My computers are connected to my modem via an ethernet switch. My modem is
> set up as a DHCP server, and my computers are DHCP enabled.
> When the input cable is disconnected from the modem (not the power, so it's
> still assigning IP addresses to my LAN) my BSD box picks up a valid internal
> IP address and subnet mask, it can ping and be pinged from all other
> computers on the LAN.
> However, when the input cable is connected to my modem, so it's connected to
> the internet, my BSD box receives nothing.  When I do an ifconfig, it shows
> NO IP address and NO subnet mask.
> I tried "dhclient rl0" which didn't work, so I checked /var/log/messages and
> was told "dhcp cannot bind to address; address already in use."  I then
> tried manually assigning an IP and subnet mask, which didn't work either.
> Getting FreeBSD online has been nothing but an ordeal, and I am about ready
> to throw in the towel.  If anyone has any ideas, I would be very grateful
> indeed.

It shouldn't be that hard. In rc.conf, ifconfig_rl0="DHCP" should be all it
takes. I'm assuming you already have that though, so on to the next thing...

Could you do this: killall dhclient (wait a few seconds) then dhclient -v rl0

then cut 'n paste the results.

[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to