Hi,

I'm trying to write some code that uses /usr/ports/graphics/svgalib. 
I've started off with the first example program on:

  http://www.svgalib.org/jay/beginners_guide/beginners_guide.html

As root, I can compile and run it fine, and I get the message:

  [svgalib: allocated virtual console #10]

And if I try to run it as a normal user, I get:

  svgalib: Cannot get I/O permissions.

This is expected, because the program is not setuid root.  So as root I
chmod u+s it, but then when I run it as a normal user I get:

  You must be the owner of the current console to use svgalib.
  Not running in a graphics capable console,
  and unable to find one.
  Using RAGE driver, 8192KB.   ChipID:35 MemType:6
  Rage: BIOS reports base frequency=28.636MHz  Denominator= 31
  svgalib 1.4.3
  You must be the owner of the current console to use svgalib.
  Not running in a graphics capable console,
  and unable to find one.
  Not running in a graphics capable console,
  and unable to find one.

This is on ttyv0, btw.  I'm running X on ttyv9.

I've googled for the past hour or so, but have been unable to find
anything particularly enlightening in regards to why (most pages refer
to Linux, and I've yet to find one that gives any advice beyond chmod
u+s.)

TIA for any help you can send my way!

-Chris
_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to