I've been having problems with ncftp3 core dumping when issuing an ls command. Two things have changed since the last time I tried to use it... one I setup a firewall with ipfw and two i upgraded to 4 stable.

I ran a buildkernel and buildworld today on the machine.. here's the uname output:

uname -a
FreeBSD ns2.foolishgames.net 4.9-PRERELEASE FreeBSD 4.9-PRERELEASE #3: Thu Sep 18 10:54:20 PDT 2003 [EMAIL PROTECTED]:/usr/obj/usr/src/sys/ns2 i386



Any ideas what could be the problem? I tried disabling the firewall and it still core dumped. I first noticed it on sendmail.org's ftp, and tried it on my own as well. Looking at the core dump file, it complains about writing to a file, there is an error with a call to getline(), and a buffer overflow writing the history file.


Did anything change in the c libraries in 4.9 that could cause this? I did tried uninstalling the part and recompiling it.

Lucas Holt
[EMAIL PROTECTED]
________________________________________________________
FoolishGames.com  (Jewel Fan Site)
JustJournal.com (Free blogging)

"Only two things are infinite, the universe and human stupidity, and I'm not sure about the former."
- Albert Einstein (1879-1955)


_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to