I'm trying to recover a machine that failed to upgrade from 4.8 to 5.1 (the make installworld failed with a sh core dump half way through :(

The restore program is hosed, so I can't restore from tape. I don't have a recent backup of /home either (it's a hardware RAID-1, so I'm slacker than I should be about backups...) so I don't want to do a fresh install.

I tried to do an upgrade from the original CD I used to install it. Things go pretty smoothly, I'm able to identify the fs partitions, and select what I want to install, but after the partitions are fscked, the install spits out the message

"Hmm! I couldn't move the old kernel over!"

And asks if I want to reboot. On the Alt-F4 shell, I can see my partitions mounted under /mnt, and I can see the kernel and modules. I can move them around (and renamed them: kernel -> kernel.x) but still I get the same error message.

Has anyone had this sort of trouble before, and if so, what's the fix?


[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to