Hello! I am trying to add the package mozilla-firebird, the latest version, I guess. I 
downloaded the package mozilla-firebird-0.6.1_1.tgz from the www.freebsd.org/ports 
page (well, I followed the link to www first, of course...), and another package that 
was missing, obviously: nspr-4.3_2.tgz. Fine, I did " # pkg_add 
mozilla-firebird-0.6.1_1.tgz", which chugged along nicely, but complained; the output 
follows. When I tried to fire up the browser, nothing happened. No error, nothing. I 
guess this is due to the version conflicts that pkg_add complained about. Do I need to 
use a package *specifically* put together and pre-compiled for FreeBSD 4.8-RELEASE so 
that the pĺackages don't end up in conflict? Should I take the full port? I really 
*would* like to use Mozilla-firebird, it's my favourite. Output of uname follows at 
the bottom of the page.

Thanks for any help or explanations at all.
/Fredrik, Stockholm.

Output of complaints during pkg_add:
----------------------------------------------------------------------------------
bash-2.05b# pkg_add mozilla-firebird-0.6.1_1.tgz  
pkg_add: warning: package 'mozilla-firebird-0.6.1_1' requires 'libiconv-1.9.1_1', but 
'libiconv-1.8_2' is installed 
pkg_add: warning: package 'mozilla-firebird-0.6.1_1' requires 'lcms-1.09,1', but 
'lcms-1.09' is installed 
pkg_add: warning: package 'mozilla-firebird-0.6.1_1' requires 'libmng-1.0.5_1', but 
'libmng-1.0.4' is installed 
pkg_add: warning: package 'mozilla-firebird-0.6.1_1' requires 'imake-4.3.0_1', but 
'imake-4.3.0' is installed 
pkg_add: warning: package 'mozilla-firebird-0.6.1_1' requires 'freetype2-2.1.4_1', but 
'freetype2-2.1.3_1' is installed 
pkg_add: warning: package 'mozilla-firebird-0.6.1_1' requires 'glib-1.2.10_10', but 
'glib-1.2.10_8' is installed 
pkg_add: warning: package 'mozilla-firebird-0.6.1_1' requires 'fontconfig-2.2.90_3', 
but 'fontconfig-2.1_6' is installed 
pkg_add: warning: package 'mozilla-firebird-0.6.1_1' requires 'gettext-0.12.1', but 
'gettext-0.11.5_1' is installed 
pkg_add: warning: package 'mozilla-firebird-0.6.1_1' requires 
'XFree86-libraries-4.3.0_6', but 'XFree86-libraries-4.3.0_1' is installed 
pkg_add: warning: package 'mozilla-firebird-0.6.1_1' requires 'gtk-1.2.10_10', but 
'gtk-1.2.10_9' is installed 
pkg_add: warning: package 'mozilla-firebird-0.6.1_1' requires 'Xft-2.1.2', but 
'Xft-2.1_3' is installed 
pkg_add: warning: package 'mozilla-firebird-0.6.1_1' requires 'ORBit-0.5.17_1', but 
'ORBit-0.5.17' is installed 
 
====================================================================== 
Mozilla Firebird will work with either of the port versions of perl,  
provided you do "use.perl port". It will NOT work with the -STABLE  
base-system versions of Perl. 
 
If you use the lang/perl5.8 port, please remove the File::Spec package with 
the command "pkg_deinstall -f p5-File-Spec". If you are updating to the 5.8 
version of perl, please do this *first*. 
 
Any bug reports should be addressed to the maintainers at: 
        [EMAIL PROTECTED] 
You may also Cc: [EMAIL PROTECTED] Please do not send 
bug reports to any other addresses.  
 
Please include the following information with any bug report: 
* Output from 'uname -a'. 
* Date/time stamp from www/mozilla-firebird/Makefile. 
* Perl version used (/usr/bin/perl --version or  
        /usr/local/bin/perl --version for -current). 
* Where/when did the problem occur: configuring, building, or 
        running mozilla-firebird? 
* How can you reproduce the problem? 
 
Thank you for your help in testing and reporting bugs, and we hope you 
enjoy using Firebird. 
The Maintainers (gnome@) 
 
Additional notes: 
 
0.6: 
Update to 0.6 version, rename from phoenix to Mozilla Firebird, all 
internal names updated accordingly. 
 
0.4_8: 
Add patch to fix network ops on -CURRENT. 
 
0.4_9: 
Install link to java plugin. 
Build plist after install using find/sed. 
 
0.4_10: 
Backdown after failed 0.5 from nonofficial tree. Makefile modifications 
to generate plist done right this time. 
 
0.5_1 
Official 0.5 release port. 
 
****WARNING! DANGER, WILL ROBINSON!**** You must delete your old .phoenix 
dir! Save your bookmarks.html somewhere and then let it create a new 
directory. You can import your old bookmark file. Bug reports from people 
who did not do this are going to be taken at extremely low priority. 
 
Also, please see the nifty new phoenix themes and extensions at the new 
website http://texturizer.net/phoenix/index.html. 
 
Finally make portlint STFU about the Makefile. 
 
The distfile is on my distfiles dir this time, so I have mirrored it on my 
html page until the distfiles dir gets mirrored in 24-48 hours. 
 
I had to disable Xinerama since it was breaking the build. 
 
0.5_4 
Patch to hopefully fix crash when formatting time string at end of download. 
Thanks to Greg Rumple and Joe Marcus Clarke for the fantastic work debugging 
this one. 
 
Added /usr/X11R6/bin/firebird.rb. If you have ruby installed, you can run 
this instead of 'firebird' and it takes care of the 'profile in use' errors 
by automatically using an existing phoenix if one is running. I didn't put 
a dependency because I don't want to require ruby + ruby-shim to run the 
browser. 
====================================================================== 
 
----------------------------------------------------------------------------------


----------------------------------------------------------------------------------
" # uname -a":
FreeBSD <hostname removed> 4.8-RELEASE FreeBSD 4.8-RELEASE #0: Thu Apr  3 10:53:38 GMT 
2003     [EMAIL PROTECTED]:/usr/obj/usr/src/sys/GENERIC  i386
----------------------------------------------------------------------------------

_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to