I've been struggling with this problem for the last week and I am close to
getting it to work, but I seem to be missing something.

I currently have a HP DeskJet 870Cse hooked up via lpt0 to FreeBSD 5.1
i386 machine.  I can print text files via lpr with no problem.  This is
done through apsfilter.  I have been able to print from other BSD machines
on the network.

However, when I try to print from my Windows 2000 Server machine, it
fails.  I have Samba installed on my print server and I can see the
printer from explorer on my windows box, but any attempt to access them
gives me a  security error.  I have tried using the wizard for setting up
printers and it would complete successfully, however the test page would
not print.  The windows queue would state that the printer is either busy
or was not allowed to print there.  I suspect that there is some security
protocol in Samba that I need to remove, but I don't know what that is...

The logs from samba and the spools are empty.

my /etc/printcap file:

# APS1_BEGIN:printer1
# - don't delete start label for apsfilter printer1
# - no other printer defines between BEGIN and END LABEL
# APS1_END - don't delete this


my smb.conf file:

   workgroup = WORK
   server string = printer
   hosts allow = 192.168.1. 127.
   load printers = yes
   printcap name = /etc/printcap
   printing = bsd
   guest account = root
   log file = /var/log/samba.log.%m
   max log size = 50
   security = share
   socket options = TCP_NODELAY
   interfaces =
   domain master = yes
   preferred master = yes
   dns proxy = no

   load printers = yes
   use client driver = yes
   show add printer wizard

   comment = Home Directories
   public = no
   browseable = no
   writeable = yes

   comment = HP DeskJet 870Cse
   path = /var/spool/samba
   browseable = yes
   public = yes
   printable = yes

I have tried multiple combinations of variables in my smb.conf but have
been unsuccessful.  I've tried using some of the combinations found in
various webpages, but it seems that most are out of date as their
parameters for samba are deprecated.

Any and all help is greatly appreciated.  Thanks in advance.

--Andy Clements

[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to