On Mon, Sep 22, 2003 at 01:40:56PM +0000, [EMAIL PROTECTED] wrote:
> Hi,
> I am not able to use cvsup (I have tried other cvsup*)
>  # cvsup -g -L 2 /root/ports-supfile
>  Parsing supfile "/root/ports-supfile"
>  Connecting to cvsup1.FreeBSD.org
>  Cannot connect to cvsup1.FreeBSD.org: Connection refused
>  Will retry at 17:47:15

I assume you've tried connecting on several occasions (cvsup servers
can't support a huge number of clients simultaneously cvsup'ing, so
it's not unusual to occasionally have to wait one's turn to get onto a
server.) Then there's the old standby for the impatient of trying
other cvsup servers.
> I looked at the CVSup home page and so did the following:
>  bash-2.05b$ netstat -na |grep 5999
>  tcp4       0      0  *.5999                 *.*                    LISTEN

Hmmm... This suggests that you are running a cvsup server on your
local system.  That's all very well and good, but it doesn't really
help you, running a cvsup client, to connect onto a remote cvsup

The fact that there's no established connection is, well, exactly what
cvsup told you itself already.
> Two bits of information:
> * I am accessing via a firewall. I able to browse the web, send/get mail etc. 

This, I suspect is the cause of all of your problems.  I'd be fairly
certain that the firewall config is preventing you from connecting to
remote hosts on port 5999.  Presumably this firewall is not under your
control (or else you'ld have given us some clue about what sort of
firewall it was and how you have configured it)?  In which case the
best thing to do is talk to the firewall administrators: they may be
willing to change the config permit you to access a cvsup server once
they understand what that is and that it's no threat to their
network. Or they may run socks or other proxy servers which are
available for you to use.

You can try using telnet(1) to test connectivity, but this doesn't
really tell you much more than using cvsup directly:

    % telnet cvsup.uk.freebsd.org 5999
    Connected to cvsup.plig.net.
    Escape character is '^]'.
    OK 17 0 SNAP_16_1f CVSup server ready
    telnet> q
    Connection closed.

If the firewall is filtering out connections to port 5999 then you'll
hang before the 'Connected to cvsup....' line is printed out.
Unfortunately, you'll probably see exactly the same effect if the
remote server isn't actually running cvsupd(8) so it's not a 100%
reliable diagnostic test.

> * I can ping to hosts in the internal network, but not external hosts.

If your firewall includes a NAT gateway, then it's often the case that
you can't ping through it.  Or your firewall administrators may just
not like you to ping internet hosts.  However, this is unlikely to
have any direct relevance to solving your cvsup(1) problem.



Dr Matthew J Seaman MA, D.Phil.                       26 The Paddocks
                                                      Savill Way
PGP: http://www.infracaninophile.co.uk/pgpkey         Marlow
Tel: +44 1628 476614                                  Bucks., SL7 1TH UK

Attachment: pgp00000.pgp
Description: PGP signature

Reply via email to