Hi,

Trying to configure sasl with postfix.. and I keep getting "Login
Failed"

Here's what I have:

telnet localhost 25:
AUTH PLAIN Y2hhcm...
535 Error: authentication failed

The maillog simply shows:
warning: localhost[127.0.0.1]: SASL PLAIN authentication failed

/etc/rc.conf:
sasl_saslauthd_enable="YES"
sasl_saslauthd_flags="-a getpwent"

/usr/local/lib/sasl2/smtpd.conf
pwcheck_method: saslauthd
mech_list: plain login

I'm not using pam for anything else, so I figured that this method had
the best chance of working :)
Postfix is NOT chrooted, and postfix is in group mail.

Postfix config:

 smtpd_sasl_auth_enable = yes
 smtpd_sasl_security_options = noanonymous
 smtpd_sasl_local_domain =
 broken_sasl_auth_clients = yes

Here's the perms on saslauthd:
drwxrwx---   2 cyrus  mail   512 Sep 23 17:27 saslauthd/

Am I missing anything?
I tried adding -d to saslauthd_flags in rc.conf. When I started
saslauthd, it just hung there, like I expected, only, I didn't get any
output when I tried to login to postfix.

help would be greatly appreciated.

-Charlie
_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to