On Fri, 2003-09-26 at 02:46, Jon Noack wrote:
> nmap 3.46 from ports fails to build on my 5.1-RELEASE-p8 machine with 
> the following error (full build log attached):
> 
> *************************** error ***************************
> c++ -c  -I/usr/local/include -O -pipe -march=pentium3 -fmemoize-lookups 
> -fsave-memoized -Wall  -I/usr/local/include -Ilibpcap-possiblymodified 
> -Inbase -Insock/include  -DHAVE_CONFIG_H -DNMAP_VERSION=\"3.46\" 
> -DNMAP_NAME=\"nmap\" -DNMAP_URL=\"http://www.insecure.org/nmap/\";
> -DNMAP_PLATFORM=\"i386-portbld-freebsd5.1\" 
> -DNMAPDATADIR=\"/usr/local/share/nmap\" -Ilibpcap-possiblymodified 
> main.cc -o main.o
> In file included from nbase/nbase.h:256,
>                   from nmap.h:109,
>                   from main.cc:87:
> /usr/local/include/getopt.h:115: declaration of C function `int getopt()'
>     conflicts with
> /usr/include/unistd.h:377: previous declaration `int getopt(int, char* 
> const*,
>     const char*)' here
> *** Error code 1
> *************************************************************

I'm having the same problem. I think it has something to do with pcre,
but I'm not sure yet. I'll report back if I find something more.

-- 
Adam McLaurin <[EMAIL PROTECTED]>

Attachment: signature.asc
Description: This is a digitally signed message part

Reply via email to