On Sat, 2003-09-27 at 14:17, stan wrote:
> I cvsup'd today (main and ports), then did a portupgrade -aRR, and now I
> can't get loged intot a session using gdm.
> I've rebooted the machine, and blown awa ~/.g[cn]* in my user home
> directory. Still no luck. I tried the "Gnome failsafe" session, still no
> luck. Looks like it doesn't even _try_ to start Gnome, and I get a console
> message about 
>  gdm_slave_session_start: Execution of PostLogin script returned > 0. Aborting.

Heh... same thing happened to me. Here is what you need to do:

cd into /usr/X11R6/etc/gdm. There you find your gdm.conf. After the
cvsup, you have (or have a newer version of) factory-gdm.conf. A
comparison showed wha'ts missing. Go ahead and edit gdm.conf. Search for
"PostSessionScriptDir". You should see a path assigned to it. You should
also see a definition of "PreSessionScriptDir". What you don't see is
"PostLoginScriptDir". Go ahead and add to that section following line:

Then restart gdm ("/usr/X11R6/etc/rc.d/gdm.sh stop" and 
"/usr/X11R6/etc/rc.d/gdm.sh start") and you should be good to go.

Hope this helps,

Attachment: signature.asc
Description: This is a digitally signed message part

Reply via email to