Hello All,

I have googled, but it seems noone ever answered it or I just did
not search correctly, but ...

I have only tried this on FreeBSD 5.1-RELEASE. I am trying to
install perl5.8 (ports) with threads support and it bombs out with the
following error:


`sh  cflags "optimize='-O -pipe -mcpu=pentiumpro'" opmini.o`  -DPERL_EXTERNAL_GLOB 
          CCCMD =  cc -DPERL_CORE -c -DAPPLLIB_EXP="/usr/local/lib/perl5/5.8.0/BSDPAN" 
trict-aliasing -I/usr/local/include -O -pipe -mcpu=pentiumpro -Wall
rm -f opmini.c
cc -pthread -Wl,-E  -L/usr/local/lib -o miniperl  miniperlmain.o opmini.o libperl.a 
-lm -lc_r -lcrypt -lutil
./miniperl -w -Ilib -MExporter -e '<?>' || make minitest
Out of memory!
cp ext/re/re.pm ext/re/re.tmp && sh mv-if-diff ext/re/re.tmp lib/re.pm
./miniperl -Ilib configpm configpm.tmp
Out of memory!
*** Error code 1

Stop in /shared/usr/ports/lang/perl5.8/work/perl-5.8.0.
*** Error code 1 (ignored)
You may see some irrelevant test failures if you have been unable
to build lib/Config.pm or lib/lib.pm.
cd t && (rm -f perl; /bin/ln -s ../miniperl perl)  &&  ./perl TEST base/*.t comp/*.t 
cmd/*.t run/*.t io/*.t op/*.t uni/*.t
Out of memory!
*** Error code 1 (ignored)
*** Error code 1 (ignored)
./miniperl -Ilib configpm configpm.tmp
Out of memory!
*** Error code 1

Stop in /shared/usr/ports/lang/perl5.8/work/perl-5.8.0.
*** Error code 1

Stop in /shared/usr/ports/lang/perl5.8.

Perhaps someone has done and seen the same thing on and knows
a solution??? If I do not pass -DWITH_THREADS to make, then
all is fine, but I want support for threads to run some application.


Odhiambo Washington   <[EMAIL PROTECTED]>  "The box said 'Requires
Wananchi Online Ltd.  www.wananchi.com      Windows 95, NT, or better,'
Tel: +254 2 313985-9  +254 2 313922         so I installed FreeBSD."   
GSM: +254 72 743223   +254 733 744121       This sig is McQ!  :-)

A novice was trying to fix a broken Lisp machine by turning the power
off and on.  Knight, seeing what the student was doing spoke sternly:
"You can not fix a machine by just power-cycling it with no
understanding of what is going wrong."  Knight turned the machine off
and on.  The machine worked.

Attachment: smime.p7s
Description: S/MIME cryptographic signature

Reply via email to